summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-05-24 15:08:31 -0400
committerGuillaume Horel2017-05-24 15:08:31 -0400
commit4be1310454986cfa5f4085018a885e39de27127e (patch)
tree0ff2fb1a54fcf721f9457d3d19f38d2a9870bf0e
parent004eba035fd7c4d2644a9b2a2e50a37a0e377a5b (diff)
downloadaur-4be1310454986cfa5f4085018a885e39de27127e.tar.gz
version bump
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e190d345731..4c4d22130dbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = python-feather
pkgdesc = Fast, interoperable binary data frame storage for Python, R
- pkgver = 0.3.1
+ pkgver = 0.4.0
pkgrel = 1
url = https://github.com/wesm/feather
- arch = i686
- arch = x86_64
+ arch = any
license = Apache
makedepends = python-setuptools
- makedepends = cython
depends = python
depends = python-pandas>=0.17.1
- source = https://github.com/wesm/feather/archive/v0.3.1.tar.gz
- md5sums = 3700893e1f21bc850c9e80446d82c185
+ depends = python-pyarrow>=0.4.0
+ source = https://github.com/wesm/feather/archive/v0.4.0.tar.gz
+ sha256sums = 62be8619cd56e5c4ba5c5095e01732ccb125ba56c83a4cba0f6e6293a5e4b348
pkgname = python-feather
diff --git a/PKGBUILD b/PKGBUILD
index a25fe5c570e8..656a34fea76b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,25 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgbase=('python-feather')
pkgname=('python-feather')
_module='feather'
-pkgver='0.3.1'
+pkgver='0.4.0'
pkgrel=1
pkgdesc="Fast, interoperable binary data frame storage for Python, R"
url="https://github.com/wesm/feather"
depends=('python'
- 'python-pandas>=0.17.1')
-makedepends=('python-setuptools'
- 'cython')
+ 'python-pandas>=0.17.1'
+ 'python-pyarrow>=0.4.0')
+makedepends=('python-setuptools')
license=('Apache')
-arch=('i686' 'x86_64')
+arch=('any')
source=("https://github.com/wesm/feather/archive/v$pkgver.tar.gz")
-md5sums=('3700893e1f21bc850c9e80446d82c185')
+sha256sums=('62be8619cd56e5c4ba5c5095e01732ccb125ba56c83a4cba0f6e6293a5e4b348')
build() {
cd "${srcdir}/${_module}-${pkgver}/python"
- ln -s ../cpp/src src
python setup.py build
}
package() {
cd "${srcdir}/${_module}-${pkgver}/python"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python setup.py install --root="${pkgdir}" --optimize=1
}