summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2021-04-02 15:18:08 -0400
committerBuildTools2021-04-02 15:18:08 -0400
commitc7cad44bd7984f6f31924cf756410ae2ac053117 (patch)
treef4d1e899b9658ba4d3bb7738ffeba8a06bc3ffb7
downloadaur-c7cad44bd7984f6f31924cf756410ae2ac053117.tar.gz
removing python2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae76b6bd4fc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-fedmsg
+ pkgdesc = Utilities used around Fedora Infrastructure to send and receive messages
+ pkgver = 1.1.1
+ pkgrel = 1
+ url = https://fedmsg.readthedocs.org/
+ arch = any
+ license = LGPLv2
+ depends = python-kitchen
+ depends = python-pygments
+ depends = python-pyzmq
+ depends = python-arrow
+ source = https://github.com/fedora-infra/fedmsg/archive/1.1.1.tar.gz
+ sha256sums = 3471f5a2750d2b8742f65c5957bd22ad4a7a09cb97281eb434b938837827eebc
+
+pkgname = python-fedmsg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1346fb980798
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=python-fedmsg
+pkgver=1.1.1
+pkgrel=1
+pkgdesc='Utilities used around Fedora Infrastructure to send and receive messages'
+arch=(any)
+url='https://fedmsg.readthedocs.org/'
+license=(LGPLv2)
+depends=('python-kitchen' 'python-pygments' 'python-pyzmq' 'python-arrow')
+makedeps=('python-setuptools' 'python2-setuptools')
+source=("https://pypi.python.org/packages/0e/59/3a085f378b6200a6b9eb6d8f42654fb35ac181e095221796d5248372eb2f/fedmsg-0.18.2.tar.gz")
+source=("https://github.com/fedora-infra/fedmsg/archive/${pkgver}.tar.gz")
+sha256sums=('3471f5a2750d2b8742f65c5957bd22ad4a7a09cb97281eb434b938837827eebc')
+
+package() {
+ cd "fedmsg-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Ddm755 ${pkgname}/etc/fedmsg.d
+ for file in {base.py,endpoints.py,gateway.py,ircbot.py,logging.py,relay.py,ssl.py}; do
+ install -D -m644 fedmsg.d/${file} ${pkgdir}/etc/fedmsg.d/${file}
+ done
+}
+
+# vim:set ts=2 sw=2 et: