summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConrad Sachweh2018-05-17 13:22:38 +0200
committerConrad Sachweh2018-05-17 13:22:38 +0200
commit5b3f7d9e8c4ead57a61b4b2ebc98039909ced775 (patch)
treea63508fe330595cfdb89e6efc964775bb95f3b8b
parent9027f30c53d38a4a720e63043c80c8f9c121eeb2 (diff)
downloadaur-5b3f7d9e8c4ead57a61b4b2ebc98039909ced775.tar.gz
updated dependencies
added python-lxml and python-dateutil mentioned by @fft
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD9
3 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 557085e1f541..5b48c71332a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-feedgen
pkgdesc = This module can be used to generate web feeds in both ATOM and RSS format. It has support for extensions. Included is for example an extension to produce Podcasts.
pkgver = 0.6.1
- pkgrel = 1
+ pkgrel = 2
url = http://lkiesow.github.io/python-feedgen
arch = any
license = BSD
license = GPL
+ makedepends = python-setuptools
depends = python
- depends = python-setuptools
+ depends = python-lxml
+ depends = python-dateutil
source = https://files.pythonhosted.org/packages/source/f/feedgen/feedgen-0.6.1.tar.gz
md5sums = 0356a7500222b7cb283fa02a5960a19b
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..84ad39682cb2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+*.tar
+*.xz
+*.gz
+src/
diff --git a/PKGBUILD b/PKGBUILD
index 97eec077746a..953dd259a8ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
-# Maintainer: Conrad Sachweh aur@spamthis.space
+# Maintainer: Conrad Sachweh <conrad+aur@spamthis.space>
pkgname=python-feedgen
_pkgname=feedgen
pkgver=0.6.1
-pkgrel=1
+pkgrel=2
pkgdesc="This module can be used to generate web feeds in both ATOM and RSS format. It has support for extensions. Included is for example an extension to produce Podcasts."
url="http://lkiesow.github.io/python-feedgen"
arch=('any')
license=('BSD' 'GPL')
-depends=('python' 'python-setuptools')
+depends=('python' 'python-lxml' 'python-dateutil')
+makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
md5sums=('0356a7500222b7cb283fa02a5960a19b')
package() {
cd $srcdir/${_pkgname}-${pkgver}
- python setup.py install --root="${pkgdir}" || return 1
+ python setup.py install --root="${pkgdir}/" --optimize=1
}