summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorConrad Sachweh2018-01-09 16:03:22 +0100
committerConrad Sachweh2018-01-09 16:03:22 +0100
commit9027f30c53d38a4a720e63043c80c8f9c121eeb2 (patch)
treedabd895b99820afc4bf6e35b21864c2f0964b44e
downloadaur-9027f30c53d38a4a720e63043c80c8f9c121eeb2.tar.gz
initial commit version 0.6.1-1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..557085e1f541
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-feedgen
+ pkgdesc = This module can be used to generate web feeds in both ATOM and RSS format. It has support for extensions. Included is for example an extension to produce Podcasts.
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = http://lkiesow.github.io/python-feedgen
+ arch = any
+ license = BSD
+ license = GPL
+ depends = python
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/f/feedgen/feedgen-0.6.1.tar.gz
+ md5sums = 0356a7500222b7cb283fa02a5960a19b
+
+pkgname = python-feedgen
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97eec077746a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Conrad Sachweh aur@spamthis.space
+pkgname=python-feedgen
+_pkgname=feedgen
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="This module can be used to generate web feeds in both ATOM and RSS format. It has support for extensions. Included is for example an extension to produce Podcasts."
+url="http://lkiesow.github.io/python-feedgen"
+arch=('any')
+license=('BSD' 'GPL')
+depends=('python' 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('0356a7500222b7cb283fa02a5960a19b')
+
+package() {
+ cd $srcdir/${_pkgname}-${pkgver}
+
+ python setup.py install --root="${pkgdir}" || return 1
+}