summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2020-09-10 00:20:13 +0100
committergetzze2020-09-10 00:20:13 +0100
commitca8e730352e97b9557fdb28e365d29b54ef5b488 (patch)
tree09635046cbe0799761a77d12fb6a0a522ee92923
downloadaur-ca8e730352e97b9557fdb28e365d29b54ef5b488.tar.gz
initial 6.0.0b3
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD48
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af5a9727a7f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = python-feedparser-dev
+ pkgdesc = Parse RSS and Atom feeds in Python: development version
+ pkgver = 6.0.0b3
+ pkgrel = 1
+ url = https://github.com/kurtmckee/feedparser/
+ arch = any
+ license = custom
+ makedepends = python
+ makedepends = libxml2
+ makedepends = python-setuptools
+ depends = python
+ depends = libxml2
+ provides = python-feedparser
+ conflicts = python-feedparser
+ source = feedparser-6.0.0b3.tar.gz::https://github.com/kurtmckee/feedparser/archive/6.0.0b3.tar.gz
+ source = https://files.pythonhosted.org/packages/source/s/sgmllib3k/sgmllib3k-1.0.0.tar.gz
+ sha256sums = 1387970fb350a084ad31a55c2a1a5646214b7fd3b726a7f9c6e5d9bd63412710
+ sha256sums = 7868fb1c8bfa764c1ac563d3cf369c381d1325d36124933a726f29fcdaa812e9
+
+pkgname = python-feedparser-dev
+ depends = libxml2
+ depends = python-sgmllib3k
+
+pkgname = python-sgmllib3k
+ pkgdesc = Port of sgmllib to Python3
+ license = PSF
+ depends = python
+ provides = python-sgmllib
+ conflicts = python-sgmllib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..098e6de856f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: getzze <getzze at gmail dot com>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgbase=python-feedparser-dev
+pkgname=('python-feedparser-dev' 'python-sgmllib3k')
+pkgver=6.0.0b3
+pkgrel=1
+pkgdesc="Parse RSS and Atom feeds in Python: development version"
+arch=('any')
+url="https://github.com/kurtmckee/feedparser/"
+license=('custom')
+provides=('python-feedparser')
+conflicts=('python-feedparser')
+makedepends=('python' 'libxml2' 'python-setuptools')
+depends=('python' 'libxml2')
+source=(feedparser-${pkgver}.tar.gz::https://github.com/kurtmckee/feedparser/archive/${pkgver}.tar.gz
+ https://files.pythonhosted.org/packages/source/s/sgmllib3k/sgmllib3k-1.0.0.tar.gz)
+sha256sums=('1387970fb350a084ad31a55c2a1a5646214b7fd3b726a7f9c6e5d9bd63412710'
+ '7868fb1c8bfa764c1ac563d3cf369c381d1325d36124933a726f29fcdaa812e9')
+
+
+build() {
+ cd "${srcdir}/sgmllib3k-1.0.0"
+ python /usr/lib/python3.8/compileall.py sgmllib.py
+}
+
+package_python-feedparser-dev() {
+ depends=('libxml2' 'python-sgmllib3k')
+
+ cd "${srcdir}/feedparser-${pkgver}"
+ python setup.py install --root="${pkgdir}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/license"
+}
+
+package_python-sgmllib3k() {
+ depends=('python')
+ provides=('python-sgmllib')
+ conflicts=('python-sgmllib')
+ pkgdesc="Port of sgmllib to Python3"
+ license=('PSF')
+
+ cd "${srcdir}/sgmllib3k-1.0.0"
+ install -Dm644 sgmllib.py \
+ "${pkgdir}/usr/lib/python3.8/site-packages/sgmllib.py"
+ install -Dm644 __pycache__/sgmllib.cpython-38.pyc \
+ "${pkgdir}/usr/lib/python3.8/site-packages/__pycache__/sgmllib.cpython-38.pyc"
+}
+