summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspecter1192020-01-24 21:56:22 +0000
committerspecter1192020-01-24 21:56:22 +0000
commitc020c09783c0175e25390883d9719791f3abca5a (patch)
tree75516ab1bccd8572846ace9f27581422a45e942d
downloadaur-c020c09783c0175e25390883d9719791f3abca5a.tar.gz
init commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD28
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..559c541723f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-ffmpeg-python
+ pkgdesc = Python bindings for FFmpeg - with complex filtering support
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://pypi.org/project/ffmpeg-python
+ arch = any
+ license = Apache2
+ makedepends = python-setuptools
+ depends = python
+ depends = python-future
+ source = https://files.pythonhosted.org/packages/source/f/ffmpeg-python/ffmpeg-python-0.2.0.tar.gz
+ source = https://raw.githubusercontent.com/kkroening/ffmpeg-python/master/LICENSE
+ md5sums = 1aa943ce1b4e720eec77d3ec9a225724
+ md5sums = SKIP
+
+pkgname = python-ffmpeg-python
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05a6b71700a8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/src/
+/pkg/
+/ffmpeg-python-*.tar.gz
+/LICENSE
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d748e2b38a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ke Liu <spcter119@gmail.com>
+
+pkgname=python-ffmpeg-python
+_name=${pkgname#python-}
+pkgver=0.2.0
+pkgrel=1
+pkgdesc='Python bindings for FFmpeg - with complex filtering support'
+arch=('any')
+url='https://pypi.org/project/ffmpeg-python'
+license=('Apache2')
+depends=('python' 'python-future')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/kkroening/ffmpeg-python/master/LICENSE")
+md5sums=('1aa943ce1b4e720eec77d3ec9a225724'
+ 'SKIP')
+
+build() {
+ cd "$srcdir/${_name}-$pkgver"
+ python setup.py clean --all
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${_name}-$pkgver"
+ python setup.py install --root "$pkgdir" --skip-build --optimize=1
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}