summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2022-06-07 20:57:55 +0100
committerWill Handley2022-06-07 20:57:55 +0100
commit07879e66c415a3024fd043200d6f7e24faf10348 (patch)
tree3f05f21c3da4cdde86fe5a9d0e3f8ec1d29b5e32
parent6c4b3afad91032eaaaa20398d53601f7bd811ad7 (diff)
downloadaur-07879e66c415a3024fd043200d6f7e24faf10348.tar.gz
Updated to new build
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
3 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a69509a1035c..f1bb710ea992 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-fgivenx
pkgdesc = Functional Posterior Plotter
pkgver = 2.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/williamjameshandley/fgivenx
arch = any
license = MIT
@@ -13,7 +13,7 @@ pkgbase = python-fgivenx
depends = python-mpi4py
depends = python-tqdm
options = !emptydirs
- source = https://github.com/williamjameshandley/fgivenx/archive/v2.4.0.tar.gz
- sha256sums = a42586754a0af5520d34eb8343ce8453996f9d0e391028268a3d2bf4347fd685
+ source = https://files.pythonhosted.org/packages/source/f/fgivenx/fgivenx-2.4.0.tar.gz
+ sha256sums = c7111323fb98c6eef4efc44bade90961256b3068faf20f4c09f1678dc770d912
pkgname = python-fgivenx
diff --git a/.gitignore b/.gitignore
index b20752a93bec..a6b8c850ccb9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
*.tar.gz
*.tar.xz
+*.tar.zst
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 529552360eee..b3323017ef7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=fgivenx
-pkgname=python-$_modulename
+pkgname=python-fgivenx
+_name=${pkgname#python-}
pkgver=2.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="Functional Posterior Plotter"
arch=(any)
url="https://github.com/williamjameshandley/fgivenx"
@@ -16,9 +16,15 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/v${pkgver}.tar.gz")
-sha256sums=('a42586754a0af5520d34eb8343ce8453996f9d0e391028268a3d2bf4347fd685')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(c7111323fb98c6eef4efc44bade90961256b3068faf20f4c09f1678dc770d912)
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/$_modulename-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
+