summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsigvaldm2018-06-22 19:38:07 +0200
committersigvaldm2018-06-22 19:38:07 +0200
commit2ff8ee8ec7e15ee89b08476bafcf9893aed64d04 (patch)
tree1a39af75abdfa6d5bb4b3e608d857fe84c3ecea0
parent9845c0b324e3aa1d5a26431aace866a145fd0d64 (diff)
downloadaur-2ff8ee8ec7e15ee89b08476bafcf9893aed64d04.tar.gz
Bumped to version 2018.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD13
3 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64f43d612db6..40fca5d7517e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = python-fiat
pkgdesc = Supports generation of arbitrary order instances of the Lagrange elements on lines, triangles, and tetrahedra (stable).
- pkgver = 2017.2.0
+ pkgver = 2018.1.0
pkgrel = 1
url = https://bitbucket.org/fenics-project/fiat
arch = any
groups = fenics
- license = GPL3
- makedepends = git
+ license = LGPL3
depends = python-numpy
depends = python-sympy
conflicts = python-fiat-git
options = !emptydirs
- source = fiat::git+https://bitbucket.org/fenics-project/fiat.git#tag=2017.2.0
- md5sums = SKIP
+ source = python-fiat-2018.1.0.tar.gz::https://bitbucket.org/fenics-project/fiat/downloads/fiat-2018.1.0.tar.gz
+ sha256sums = 3d897d99fdc94441f9c8720fb5a3bcaf8a0b9ede897a0600cb1f329dacec5c92
pkgname = python-fiat
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3f1864bb0ec4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 88726b347b65..422a97e19a80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,25 @@
_base=fiat
pkgname=python-${_base}
pkgdesc="Supports generation of arbitrary order instances of the Lagrange elements on lines, triangles, and tetrahedra (stable)."
-pkgver=2017.2.0
+pkgver=2018.1.0
pkgrel=1
arch=('any')
url="https://bitbucket.org/fenics-project/${_base}"
-license=('GPL3')
+license=('LGPL3')
groups=('fenics')
conflicts=('python-fiat-git')
depends=('python-numpy' 'python-sympy')
-makedepends=('git')
options=(!emptydirs)
-source=("${_base}::git+https://bitbucket.org/fenics-project/${_base}.git#tag=${pkgver}")
-md5sums=('SKIP')
+source=(${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/fenics-project/${_base}/downloads/${_base}-${pkgver}.tar.gz)
+sha256sums=('3d897d99fdc94441f9c8720fb5a3bcaf8a0b9ede897a0600cb1f329dacec5c92')
build() {
- cd ${_base}
+ cd ${srcdir}/${_base}-${pkgver}
python setup.py build
}
package() {
- cd ${_base}
+ cd ${srcdir}/${_base}-${pkgver}
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
}