summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimPilotAdamT2022-03-03 22:29:11 +0000
committerSimPilotAdamT2022-03-03 22:29:11 +0000
commit214e9d91a93d1c68464f9e686c05b488106366d1 (patch)
tree86550219ef6489f1ef49a617313ced985d2f1b06
downloadaur-214e9d91a93d1c68464f9e686c05b488106366d1.tar.gz
Initial
Signed-off-by: SimPilotAdamT <adam_tazul@outlook.com>
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD42
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8894b367e7af
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-fildem
+ pkgdesc = This project is a fork of gnomehud with the adition of a global menu bar
+ pkgver = 0.6.7
+ pkgrel = 1
+ url = https://github.com/gonzaarcr/fildem
+ arch = i686
+ arch = x86_64
+ makedepends = git
+ depends = bamf
+ depends = appmenu-gtk-module
+ depends = libkeybinder3
+ depends = libdbusmenu-gtk2
+ depends = libdbusmenu-gtk3
+ depends = python-fuzzysearch
+ depends = python-future
+ depends = dbus-python
+ provides = python3-fildem=0.6.7
+ provides = python-fildem=0.6.7
+ conflicts = python3-fildem
+ source = git+https://github.com/gonzaarcr/fildem.git#tag=0.6.7
+ md5sums = SKIP
+
+pkgname = python-fildem
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..62a911b97ed5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+fildem
+src
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6230ffa6e672
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Adam Tazul (SimPilotAadamT) <adam_tazul@outlook.com>
+
+pkgname=python-fildem
+pkgver=0.6.7
+pkgrel=1
+pkgdesc="This project is a fork of gnomehud with the adition of a global menu bar"
+arch=('i686' 'x86_64')
+url="https://github.com/gonzaarcr/fildem"
+depends=('bamf'
+ 'appmenu-gtk-module'
+ 'libkeybinder3'
+ 'libdbusmenu-gtk2'
+ 'libdbusmenu-gtk3'
+ 'python-fuzzysearch'
+ 'python-future'
+ 'dbus-python')
+makedepends=('git')
+provides=("python3-fildem=$pkgver"
+ "python-fildem=$pkgver")
+conflicts=("python3-fildem")
+source=("git+https://github.com/gonzaarcr/fildem.git#tag=$pkgver")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/fildem"
+ python3 -c "import fildem; print(fildem.__version__)"
+}
+
+build() {
+ cd "$srcdir/fildem"
+ python3 setup.py build
+}
+
+check() {
+ cd "$srcdir/fildem"
+ python3 setup.py test
+}
+
+package() {
+ cd "$srcdir/fildem"
+ python3 setup.py install --skip-build --root=$pkgdir --optimize=1
+}