summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-07-11 21:12:30 -0500
committerCarlos Aznarán Laos2023-07-11 21:12:30 -0500
commit251e0faa0efa2bae20a5e03e7498ba2dc1277b1f (patch)
tree61e5884353df1512e287bd24f080ccddba4a79ca
parent623d51f10d5433d3c65811d76ae4f144b1feb430 (diff)
downloadaur-python-filterpy.tar.gz
Drop python2
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD51
-rw-r--r--py2.install5
3 files changed, 22 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69f9e3b42060..c3d610c46022 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,18 +5,13 @@ pkgbase = python-filterpy
url = https://github.com/rlabbe/filterpy
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = python-filterpy-1.4.5.tar.gz::https://github.com/rlabbe/filterpy/archive/1.4.5.tar.gz
- sha256sums = fc371ad800ca5a5ff8b8352894a09c353b794ccc8b813c03d5187df451ccef3a
-
-pkgname = python-filterpy
- depends = python-numpy
+ makedepends = python-wheel
depends = python-scipy
depends = python-matplotlib
+ source = filterpy-1.4.5.tar.gz::https://github.com/rlabbe/filterpy/archive/1.4.5.tar.gz
+ sha512sums = 22bc58142249f32d58aa7395342f455ef97469cf26635c5551634a5e4987ad7ef559ead38a3ebacfa447927c96f6ded5d08d2273ec8e86a26288c851ca6a63e5
-pkgname = python2-filterpy
- install = py2.install
- depends = python2-numpy
- depends = python2-scipy
- depends = python2-matplotlib
+pkgname = python-filterpy
diff --git a/PKGBUILD b/PKGBUILD
index 8a96f1f2b42f..2b5761520a3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,25 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: tuftedocelot <tuftedocelot@fastmail.fm>
-
-pkgname=('python-filterpy' 'python2-filterpy')
+_base=filterpy
+pkgname=python-${_base}
pkgver=1.4.5
pkgrel=2
-pkgdesc='Kalman filtering and optimal estimation library'
-arch=('any')
-url='https://github.com/rlabbe/filterpy'
-license=('MIT')
-makedepends=('python-setuptools' 'python2-setuptools')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('fc371ad800ca5a5ff8b8352894a09c353b794ccc8b813c03d5187df451ccef3a')
-
-prepare() {
- cp -a "filterpy-$pkgver" "filterpy-$pkgver-py2"
-}
+pkgdesc="Kalman filtering and optimal estimation library"
+arch=(any)
+url="https://github.com/rlabbe/${_base}"
+license=(MIT)
+depends=(python-scipy python-matplotlib)
+makedepends=(python-build python-installer python-setuptools python-wheel)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('22bc58142249f32d58aa7395342f455ef97469cf26635c5551634a5e4987ad7ef559ead38a3ebacfa447927c96f6ded5d08d2273ec8e86a26288c851ca6a63e5')
build() {
- pushd "filterpy-$pkgver"
- python setup.py build
- popd
-
- pushd "filterpy-$pkgver-py2"
- python2 setup.py build
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
-package_python-filterpy() {
- depends=('python-numpy' 'python-scipy' 'python-matplotlib')
-
- cd "filterpy-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
-}
-
-package_python2-filterpy() {
- depends=('python2-numpy' 'python2-scipy' 'python2-matplotlib')
- install=py2.install
-
- cd "filterpy-$pkgver-py2"
- python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+package() {
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
-# vim:set ts=2 sw=2 et:
diff --git a/py2.install b/py2.install
deleted file mode 100644
index 40c9130fe7c0..000000000000
--- a/py2.install
+++ /dev/null
@@ -1,5 +0,0 @@
-post_install() {
- echo ':: This package will be deprecated and moved to its own pkgbase for the 2.0 release.'
- echo ':: See upstream documentation for more information.'
- echo ':: https://github.com/rlabbe/filterpy'
-}