summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-21 23:01:20 -0500
committerLuis Martinez2021-09-21 23:01:20 -0500
commit623d51f10d5433d3c65811d76ae4f144b1feb430 (patch)
tree5a4055ad9528c89ac1021e16c37830b04e6ae866
parent0419781bf336f68442c254371a8ee45b8aa0d3a3 (diff)
downloadaur-623d51f10d5433d3c65811d76ae4f144b1feb430.tar.gz
package cleanup; deprecation notice for python2
python2-filterpy will be moved to its own pkgbase once version 2.0 releases, per upstream's notice.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--py2.install5
3 files changed, 45 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5994091408a0..69f9e3b42060 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
pkgbase = python-filterpy
- pkgdesc = Kalman filtering and optimal estimation library in Python.
+ pkgdesc = Kalman filtering and optimal estimation library
pkgver = 1.4.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rlabbe/filterpy
arch = any
license = MIT
makedepends = python-setuptools
- makedepends = python-numpy
- makedepends = python-scipy
- makedepends = python-matplotlib
- source = https://github.com/rlabbe/filterpy/archive/1.4.5.tar.gz
+ makedepends = python2-setuptools
+ source = python-filterpy-1.4.5.tar.gz::https://github.com/rlabbe/filterpy/archive/1.4.5.tar.gz
sha256sums = fc371ad800ca5a5ff8b8352894a09c353b794ccc8b813c03d5187df451ccef3a
pkgname = python-filterpy
+ depends = python-numpy
+ depends = python-scipy
+ depends = python-matplotlib
pkgname = python2-filterpy
-
+ install = py2.install
+ depends = python2-numpy
+ depends = python2-scipy
+ depends = python2-matplotlib
diff --git a/PKGBUILD b/PKGBUILD
index 088d4890f194..8a96f1f2b42f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,44 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: tuftedocelot <tuftedocelot@fastmail.fm>
pkgname=('python-filterpy' 'python2-filterpy')
pkgver=1.4.5
-pkgrel=1
-pkgdesc='Kalman filtering and optimal estimation library in Python.'
+pkgrel=2
+pkgdesc='Kalman filtering and optimal estimation library'
arch=('any')
url='https://github.com/rlabbe/filterpy'
license=('MIT')
-makedepends=('python-setuptools' 'python-numpy' 'python-scipy' 'python-matplotlib')
-source=("https://github.com/rlabbe/filterpy/archive/$pkgver.tar.gz")
+makedepends=('python-setuptools' 'python2-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('fc371ad800ca5a5ff8b8352894a09c353b794ccc8b813c03d5187df451ccef3a')
+prepare() {
+ cp -a "filterpy-$pkgver" "filterpy-$pkgver-py2"
+}
+
+build() {
+ pushd "filterpy-$pkgver"
+ python setup.py build
+ popd
+
+ pushd "filterpy-$pkgver-py2"
+ python2 setup.py build
+}
+
package_python-filterpy() {
- cd "$srcdir"/filterpy-$pkgver
- python setup.py install --root="$pkgdir" --optimize=1
- install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+ depends=('python-numpy' 'python-scipy' 'python-matplotlib')
+
+ cd "filterpy-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
package_python2-filterpy() {
- cd "$srcdir"/filterpy-$pkgver
- python2 setup.py install --root="$pkgdir" --optimize=1
- install -Dm 644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname}/LICENSE
+ depends=('python2-numpy' 'python2-scipy' 'python2-matplotlib')
+ install=py2.install
+
+ cd "filterpy-$pkgver-py2"
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
# vim:set ts=2 sw=2 et:
diff --git a/py2.install b/py2.install
new file mode 100644
index 000000000000..40c9130fe7c0
--- /dev/null
+++ b/py2.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo ':: This package will be deprecated and moved to its own pkgbase for the 2.0 release.'
+ echo ':: See upstream documentation for more information.'
+ echo ':: https://github.com/rlabbe/filterpy'
+}