summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-02-05 20:02:09 +0100
committerPhilipp A2019-02-05 20:02:09 +0100
commit016e57a84a0a07ab89f818672326e51572afce05 (patch)
treee7aed6f8d5368c4bfe7c32bed1971cb20aa03998
downloadaur-016e57a84a0a07ab89f818672326e51572afce05.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5a711331dfa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-fintech
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = https://github.com/theislab/fintech
+ arch = any
+ license = custom:restricted use
+ makedepends = python-pip
+ depends = python-certifi
+ depends = python-fpdf>=1.7.2
+ depends = python-lxml
+ noextract = fintech-5.2.0-cp37-none-any.whl
+ source = https://files.pythonhosted.org/packages/cp37/f/fintech/fintech-5.2.0-cp37-none-any.whl
+ sha256sums = ff189b7c97f4600d49f25a960e5faf28c3b2dd16efeab494776e2c7a80393e78
+
+pkgname = python-fintech
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9731419a6e92
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg.tar.xz
+/*.whl
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c2049837330
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=fintech
+pkgname=python-$_name
+pkgver=5.2.0
+pkgrel=1
+pkgdesc=''
+arch=(any)
+url="https://github.com/theislab/$_name"
+license=('custom:restricted use')
+depends=(python-certifi 'python-fpdf>=1.7.2' python-lxml)
+makedepends=(python-pip)
+_wheel="$_name-$pkgver-cp37-none-any.whl"
+source=("https://files.pythonhosted.org/packages/cp37/${_name::1}/$_name/$_wheel")
+sha256sums=('ff189b7c97f4600d49f25a960e5faf28c3b2dd16efeab494776e2c7a80393e78')
+noextract=("$_wheel")
+
+package() {
+ cd "$srcdir"
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+}