summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2021-12-18 17:40:11 +0100
committerPhilipp A2021-12-18 17:40:11 +0100
commit0c8ea63fafe39cba469407fc823cdc47218f6438 (patch)
treeb858349f01d4987959137cfce8c8003f633e433e
parent7a3c61a2dca43f324e3a9f4e46b3be501a99cb02 (diff)
downloadaur-0c8ea63fafe39cba469407fc823cdc47218f6438.tar.gz
v6.6.5
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3dabecc429e..b50ac1b07f06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-fintech
pkgdesc = Finance tech: SEPA, EBICS & more
- pkgver = 6.1.1
+ pkgver = 6.6.5
pkgrel = 1
- url = https://www.joonis.de/fintech
+ url = https://www.joonis.de/en/fintech/
arch = any
license = custom:restricted use
+ depends = python>=3.9
+ depends = python<3.10
depends = python-certifi
depends = python-fpdf>=1.7.2
depends = python-lxml
- noextract = fintech-6.1.1-cp38-none-any.whl
- source = https://files.pythonhosted.org/packages/cp38/f/fintech/fintech-6.1.1-cp38-none-any.whl
+ noextract = fintech-6.6.5-cp39-none-any.whl
+ source = https://files.pythonhosted.org/packages/cp39/f/fintech/fintech-6.6.5-cp39-none-any.whl
sha256sums = 01cdf6e983b335601b53db04d6fd29a95c6906e88c89336fd20fc6985a1a1bdc
pkgname = python-fintech
-
diff --git a/PKGBUILD b/PKGBUILD
index 305c0a50dab9..920feb0f37de 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
_name=fintech
pkgname=python-$_name
-pkgver=6.1.1
+pkgver=6.6.5
pkgrel=1
pkgdesc='Finance tech: SEPA, EBICS & more'
arch=(any)
-url="https://www.joonis.de/$_name"
+url="https://www.joonis.de/en/$_name/"
license=('custom:restricted use')
-depends=(python-certifi 'python-fpdf>=1.7.2' python-lxml)
-_pyarch=cp38
+_pyminor=9
+depends=("python>=3.$_pyminor" "python<3.$((_pyminor + 1))" python-certifi 'python-fpdf>=1.7.2' python-lxml)
+_pyarch=cp3$_pyminor
_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
sha256sums=('01cdf6e983b335601b53db04d6fd29a95c6906e88c89336fd20fc6985a1a1bdc')
noextract=("$_wheel")
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ local site="$pkgdir/usr/lib/python3.$_pyminor/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
}