summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2020-08-20 13:30:34 +0200
committerfordprefect2020-08-20 13:30:34 +0200
commit94f53014c46350c123a7f92abe52bdac61b0c53c (patch)
tree0737e1b89bd1c10964ed35b0ba9d1e2c247fc9ba
parent737507a6d4c772857beff2d595ce697af5711614 (diff)
downloadaur-94f53014c46350c123a7f92abe52bdac61b0c53c.tar.gz
drep python2 version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 8 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a4029839678..82b9143fd5d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,24 +5,16 @@ pkgbase = python-fipy
url = http://www.ctcms.nist.gov/fipy
arch = any
license = custom:Public Domain
- makedepends = python2-setuptools
makedepends = python-setuptools
makedepends = python
makedepends = python-future
- makedepends = python2-future
- optdepends = gmsh: creation of irregular meshes
- source = fipy-3.4.2.1.tar.gz::https://github.com/usnistgov/fipy/archive/3.4.2.1.tar.gz
- sha256sums = f7dfeb1aaf7c723c7287e7c9a6978f2c7c4828a87bfa11d901b0f8c319a3b0ee
-
-pkgname = python-fipy
depends = python
depends = python-numpy
depends = python-scipy
depends = python-matplotlib
+ optdepends = gmsh: creation of irregular meshes
+ source = fipy-3.4.2.1.tar.gz::https://github.com/usnistgov/fipy/archive/3.4.2.1.tar.gz
+ sha256sums = f7dfeb1aaf7c723c7287e7c9a6978f2c7c4828a87bfa11d901b0f8c319a3b0ee
-pkgname = python2-fipy
- depends = python2
- depends = python2-numpy
- depends = python2-scipy
- depends = python2-matplotlib
+pkgname = python-fipy
diff --git a/PKGBUILD b/PKGBUILD
index faf512f34875..9b0608a83640 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-pkgname=("python-fipy" "python2-fipy")
-pkgbase="python-fipy"
+pkgname=python-fipy
pkgver=3.4.2.1
pkgrel=1
pkgdesc="Partial differential equation solver for Python, based on finite volume approach."
arch=('any')
url="http://www.ctcms.nist.gov/fipy"
license=('custom:Public Domain')
-makedepends=('python2-setuptools' 'python-setuptools' 'python' 'python-future' 'python2-future')
+makedepends=('python-setuptools' 'python' 'python-future')
+depends=('python' 'python-numpy' 'python-scipy' 'python-matplotlib')
optdepends=('gmsh: creation of irregular meshes')
source=("fipy-$pkgver.tar.gz::https://github.com/usnistgov/fipy/archive/${pkgver}.tar.gz")
sha256sums=('f7dfeb1aaf7c723c7287e7c9a6978f2c7c4828a87bfa11d901b0f8c319a3b0ee')
@@ -18,18 +18,7 @@ prepare(){
2to3 --write --doctests_only . || true
}
-package_python2-fipy() {
- depends=('python2' 'python2-numpy' 'python2-scipy' 'python2-matplotlib')
- cd "${srcdir}/fipy-${pkgver}"
- # fix building by removing ez_setup references
- python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
- chmod 644 ${pkgdir}/usr/lib/python*/site-packages/FiPy-${pkgver}-py*.egg-info/*
- install -Dm644 "${srcdir}/fipy-${pkgver}/LICENSE.rst" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
-
-package_python-fipy() {
- depends=('python' 'python-numpy' 'python-scipy' 'python-matplotlib')
+package() {
cd "${srcdir}/fipy-${pkgver}-py3"
# fix building by removing ez_setup references
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1