summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWil Thomason2020-04-07 18:25:21 -0400
committerWil Thomason2020-04-07 18:25:21 -0400
commitae21f2cc225abf18c06cf8800b5e1ecd316d8d99 (patch)
tree88c5e8efcc5304c6e0dc6782a096ed61f0713b94
parente2a23f0432ef1157ecb049ce5e27e9a79dc5bb89 (diff)
downloadaur-ae21f2cc225abf18c06cf8800b5e1ecd316d8d99.tar.gz
Update to v0.3.1 and remove Python 2 version
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b11adb89b3c..43e842a80d3c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,15 @@
pkgbase = python-fire
pkgdesc = Python Fire is a library for automatically generating command line interfaces (CLIs) from absolutely any Python object.
- pkgver = 0.2.1
+ pkgver = 0.3.1
pkgrel = 1
url = https://github.com/google/python-fire
arch = any
license = Apache-2.0
makedepends = python-setuptools
- makedepends = python2-setuptools
depends = python
- depends = python2
depends = python-termcolor
- depends = python2-termcolor
- source = https://github.com/google/python-fire/archive/v0.2.1.tar.gz
- sha256sums = c907e7d985d2796cc1411b21b91ed4e3b5a032dab7cbb4015469ba7300c316d8
+ source = https://github.com/google/python-fire/archive/v0.3.1.tar.gz
+ sha256sums = b0728c4a59f48ff6d1a535ceff893ec1a79a7d68257fc0e6e3a40e1bef5773a0
pkgname = python-fire
-pkgname = python2-fire
- depends = python2
-
diff --git a/PKGBUILD b/PKGBUILD
index 9396e2d888e1..2527cdbefe97 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,20 @@
_pkgbase='python-fire'
pkgbase='python-fire'
-pkgname=('python-fire' 'python2-fire')
-pkgver='0.2.1'
+pkgname=('python-fire')
+pkgver='0.3.1'
pkgrel=1
pkgdesc='Python Fire is a library for automatically generating command line interfaces (CLIs) from
absolutely any Python object.'
arch=('any')
url='https://github.com/google/python-fire'
license=('Apache-2.0')
-depends=('python' 'python2' 'python-termcolor' 'python2-termcolor')
-makedepends=('python-setuptools' 'python2-setuptools')
+depends=('python' 'python-termcolor')
+makedepends=('python-setuptools')
source=("https://github.com/google/python-fire/archive/v${pkgver}.tar.gz")
-sha256sums=('c907e7d985d2796cc1411b21b91ed4e3b5a032dab7cbb4015469ba7300c316d8')
+sha256sums=('b0728c4a59f48ff6d1a535ceff893ec1a79a7d68257fc0e6e3a40e1bef5773a0')
package_python-fire() {
cd "${srcdir}/${_pkgbase}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1
}
-
-package_python2-fire() {
- depends=('python2')
-
- cd "${srcdir}/${_pkgbase}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
-}