summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2017-10-31 22:00:29 -0200
committerandalenavals2017-10-31 22:00:29 -0200
commit4aec3c131d94a5da785d967da5d1b3e855cce4c5 (patch)
tree345a4720113dd2cd2442fda521c5ce0aaabd2072
downloadaur-4aec3c131d94a5da785d967da5d1b3e855cce4c5.tar.gz
The package build of the version python-fitsio is almost one year old
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD55
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9e900797e8a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-fitsio-git
+ pkgdesc = Python interface to gbdes pixel map (astrometry) solutions
+ pkgver = r639.844055b
+ pkgrel = 1
+ url = https://github.com/esheldon/fitsio
+ arch = any
+ license = BSD
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ source = python-fitsio-git-r639.844055b::git+https://github.com/esheldon/fitsio
+ md5sums = SKIP
+
+pkgname = python-fitsio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5576386a5235
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: E. Sheldon
+pkgname=python-fitsio-git
+pkgver=r639.844055b
+pkgrel=1
+#epoch=
+
+pkgdesc=" Python interface to gbdes pixel map (astrometry) solutions "
+
+
+arch=('any')
+url="https://github.com/esheldon/fitsio"
+license=('BSD')
+groups=()
+depends=('python' 'python-numpy')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("$pkgname-$pkgver::git+${url}")
+#noextract=()
+md5sums=('SKIP')
+#validpgpkeys=()
+
+
+build() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+
+pkgver() {
+ cd "$pkgname-$pkgver"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd "$src"
+ cd "$pkgname-$pkgver"
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+
+}