summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-10-11 19:51:58 +0000
committerGeorge Rawlinson2021-10-11 19:51:58 +0000
commit4c5daee4602e9ca08fa5165e332f6be3ffafb558 (patch)
tree156ede9ae79bba2ce895d2de031886c508083220
parent4aed4d6cac3d08b11831bf6849b48e80084695c6 (diff)
downloadaur-4c5daee4602e9ca08fa5165e332f6be3ffafb558.tar.gz
upgpkg: python-flake8-annotations 2.7.0-1
* New upstream release. * Add check dependencies.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8ca4205d0eca..523051be7224 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = python-flake8-annotations
pkgdesc = A flake8 extension that checks type annotations
- pkgver = 2.6.2
+ pkgver = 2.7.0
pkgrel = 1
url = https://github.com/sco1/flake8-annotations
arch = any
license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-pytest-check
+ checkdepends = python-pytest-cov
makedepends = python-setuptools
makedepends = python-dephell
depends = python
depends = flake8
- source = python-flake8-annotations-2.6.2.tar.gz::https://github.com/sco1/flake8-annotations/archive/v2.6.2.tar.gz
- b2sums = 726f83f16d985525ae8a3e4b834e8d1cb0f0ce2ece3002628135f30d1562a1b9cacf3e9e0b1ecfb7037282f9911409bd0cc6a8b039cfc14051f096c9f2bf6a42
+ source = python-flake8-annotations-2.7.0.tar.gz::https://github.com/sco1/flake8-annotations/archive/v2.7.0.tar.gz
+ b2sums = a48e9a7d6e7c44c52eeff7328c089bc5f15adde3bdd59394e8ad8313c53eced287858d8e3adcea8bf1147b9e37bf8a354ef8d92aa21cad0882d7d49d610a8ab4
pkgname = python-flake8-annotations
-
diff --git a/PKGBUILD b/PKGBUILD
index 57f4bd193a73..5caef77d1101 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-flake8-annotations
_pkgname="${pkgname#python-}"
_name="${_pkgname/-/_}"
-pkgver=2.6.2
+pkgver=2.7.0
pkgrel=1
pkgdesc="A flake8 extension that checks type annotations"
arch=('any')
@@ -11,9 +11,9 @@ url="https://github.com/sco1/flake8-annotations"
license=('MIT')
depends=('python' 'flake8')
makedepends=('python-setuptools' 'python-dephell')
-#checkdepends=('python-pytest' 'python-pytest-check' 'python-pytest-cov')
+checkdepends=('python-pytest' 'python-pytest-check' 'python-pytest-cov')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-b2sums=('726f83f16d985525ae8a3e4b834e8d1cb0f0ce2ece3002628135f30d1562a1b9cacf3e9e0b1ecfb7037282f9911409bd0cc6a8b039cfc14051f096c9f2bf6a42')
+b2sums=('a48e9a7d6e7c44c52eeff7328c089bc5f15adde3bdd59394e8ad8313c53eced287858d8e3adcea8bf1147b9e37bf8a354ef8d92aa21cad0882d7d49d610a8ab4')
prepare() {
cd "$_pkgname-$pkgver"
@@ -25,17 +25,19 @@ build() {
python setup.py build
}
-#check() {
-# cd "$_pkgname-$pkgver"
-# pytest --ignore testing/test_flake8_actually_runs_checker.py .
-#}
+check() {
+ cd "$_pkgname-$pkgver"
+ pytest --ignore testing/test_flake8_actually_runs_checker.py .
+}
package() {
cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ # license
install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
- # delete unnecessary files/folders
+ # delete tests folder
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
rm -rf "$pkgdir/$site_packages/testing"
}