summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2020-06-04 16:41:04 +0200
committerneodarz2020-06-04 16:41:04 +0200
commit863041c39ba7fa05beea78c47967b91e6b058d59 (patch)
treed4d0d0a38a85c1dd9eafee0f2e0e3930fd2e6897
downloadaur-863041c39ba7fa05beea78c47967b91e6b058d59.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8728bb5baf34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-flake8-annotations-complexity
+ pkgdesc = flake8 plugin to validate annotations complexity
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/best-doctor/flake8-annotations-complexity
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/best-doctor/flake8-annotations-complexity/archive/v0.0.4.tar.gz
+ sha512sums = 47f3b86e713f6d9e07a93fcb4faac2b371d6b1bf65a709468d3c7e96e764a893b22c7a5321736f40ff827c94bb964677f662de873abb8ac63c1e2361206ef87c
+
+pkgname = python-flake8-annotations-complexity
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0df3bace20e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+_pkgname=flake8-annotations-complexity
+pkgname=python-$_pkgname
+
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="flake8 plugin to validate annotations complexity"
+
+url='https://github.com/best-doctor/flake8-annotations-complexity'
+arch=('any')
+license=('MIT')
+
+depends=('python')
+
+source=("https://github.com/best-doctor/$_pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('47f3b86e713f6d9e07a93fcb4faac2b371d6b1bf65a709468d3c7e96e764a893b22c7a5321736f40ff827c94bb964677f662de873abb8ac63c1e2361206ef87c')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+