summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2020-06-04 16:45:13 +0200
committerneodarz2020-06-04 16:45:13 +0200
commit313c5208fc410ae82bfab694bad66aff6a218bcd (patch)
tree595d864c5457332ffe00f219da84acc6a42ef3c5
downloadaur-313c5208fc410ae82bfab694bad66aff6a218bcd.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..637b41e6c940
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-flake8-bandit
+ pkgdesc = Automated security testing using bandit and flake8.
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/best-doctor/flake8-annotations-complexity
+ arch = any
+ license = MIT
+ depends = python
+ depends = bandit
+ source = https://github.com/tylerwince/flake8-bandit/archive/v2.1.0.tar.gz
+ sha512sums = 28e637d9dd59a18954b61b68c001a11784c5b0c750ef0701f04041f2cfd66ba4c33469f1bb8a338ac4016f70bdf44f4532c2bf67c9d8b822e7c8d1881b0b427c
+
+pkgname = python-flake8-bandit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ab14ca9c37b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+_pkgname=flake8-bandit
+pkgname=python-$_pkgname
+
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Automated security testing using bandit and flake8."
+
+url='https://github.com/best-doctor/flake8-annotations-complexity'
+arch=('any')
+license=('MIT')
+
+depends=('python' 'bandit')
+
+source=("https://github.com/tylerwince/$_pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('28e637d9dd59a18954b61b68c001a11784c5b0c750ef0701f04041f2cfd66ba4c33469f1bb8a338ac4016f70bdf44f4532c2bf67c9d8b822e7c8d1881b0b427c')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+