summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 20:19:55 +0200
committerAntonio Rojas2022-04-01 20:19:55 +0200
commit80d6da916e68ec736c878d3b185ede38ca09f89a (patch)
treea467dbb067e3790874558ba792ea105608662af7
downloadaur-80d6da916e68ec736c878d3b185ede38ca09f89a.tar.gz
import from community
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54b28edfbef5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-flake8-blind-except
+ pkgdesc = A flake8 extension that checks for blind except: statements
+ pkgver = 0.2.0
+ pkgrel = 2
+ url = https://github.com/elijahandrews/flake8-blind-except
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-setuptools
+ source = https://github.com/elijahandrews/flake8-blind-except/archive/v0.2.0/python-flake8-blind-except-0.2.0.tar.gz
+ sha512sums = e96ca3e9cf6fa0d5f155f2136bfc150c6726591184d84f48b77385fda32727f4fa780563a7dc404bd8b0329fc2200f6ac796c5e644565155e51f4140e1eba0cd
+
+pkgname = python-flake8-blind-except
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa3695b2031e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python-flake8-blind-except
+pkgver=0.2.0
+pkgrel=2
+pkgdesc='A flake8 extension that checks for blind except: statements'
+arch=('any')
+license=('MIT')
+url='https://github.com/elijahandrews/flake8-blind-except'
+depends=('python-setuptools')
+makedepends=('python-setuptools')
+source=("https://github.com/elijahandrews/flake8-blind-except/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('e96ca3e9cf6fa0d5f155f2136bfc150c6726591184d84f48b77385fda32727f4fa780563a7dc404bd8b0329fc2200f6ac796c5e644565155e51f4140e1eba0cd')
+
+build() {
+ cd flake8-blind-except-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd flake8-blind-except-$pkgver
+ python setup.py install --root="$pkgdir"/ --optimize=1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}