summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-03-29 17:00:06 -0500
committerCarlos Aznarán2024-03-29 17:00:06 -0500
commit60e7c5e68b93291510f41322d9d74b81cd2b58a8 (patch)
tree40eaf300d0a0dcaa1733c7c539668d53368e84a0
parent8090d6cfb385d5660c111283e35720c4fb962fb7 (diff)
downloadaur-60e7c5e68b93291510f41322d9d74b81cd2b58a8.tar.gz
Bump version to 2.3.0
-rw-r--r--.SRCINFO13
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD8
3 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8252c774c6d..c0bf7ac25130 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = python-flake8-builtins
pkgdesc = Check for python builtins being used as variables or parameters
- pkgver = 2.2.0
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/gforcada/flake8-builtins
arch = any
- license = GPL2
+ license = GPL-2.0-or-later
checkdepends = python-pytest
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-hatchling
+ makedepends = python-wheel
depends = flake8
- source = flake8-builtins-2.2.0.tar.gz::https://github.com/gforcada/flake8-builtins/archive/2.2.0.tar.gz
- sha512sums = 2223b8151032aed3c58393113b54f285555684b48061bd38a99f30ad4efcf1dfc0cdd579faaba2a764354e4503ae36faa5605bc98411554673361da785401275
+ source = flake8-builtins-2.3.0.tar.gz::https://github.com/gforcada/flake8-builtins/archive/2.3.0.tar.gz
+ sha512sums = e4aeb5bfd95f2f8bfd5b6404deff76fc2094dc432d5870d38752051d4851ba6953741704304c0a3665c0976240c3e26d39b62389c96cc83653d1436c9d8d5b0a
pkgname = python-flake8-builtins
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..4be4d3510f40
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[python-flake8-builtins]
+source = "github"
+github = "gforcada/flake8-builtins"
+use_max_tag = "true" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index e622152d46fd..cc32e2f5fdf0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: acxz <akashpatel2008@yahoo.com>
_base=flake8-builtins
pkgname=python-${_base}
-pkgver=2.2.0
+pkgver=2.3.0
pkgrel=1
pkgdesc="Check for python builtins being used as variables or parameters"
-arch=('any')
+arch=(any)
url="https://github.com/gforcada/${_base}"
-license=(GPL2)
+license=(GPL-2.0-or-later)
depends=(flake8)
makedepends=(python-build python-installer python-hatchling python-wheel)
checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz)
-sha512sums=('2223b8151032aed3c58393113b54f285555684b48061bd38a99f30ad4efcf1dfc0cdd579faaba2a764354e4503ae36faa5605bc98411554673361da785401275')
+sha512sums=('e4aeb5bfd95f2f8bfd5b6404deff76fc2094dc432d5870d38752051d4851ba6953741704304c0a3665c0976240c3e26d39b62389c96cc83653d1436c9d8d5b0a')
build() {
cd ${_base}-${pkgver}