summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-05-30 18:24:48 -0400
committeracxz2020-05-30 18:26:27 -0400
commit2036fc518a76238e6363356e3dc9ec074c6a71a3 (patch)
tree85461b605dbbb3bce6138e70a4d2f4b0e1d3108a
downloadaur-2036fc518a76238e6363356e3dc9ec074c6a71a3.tar.gz
create python-flake8-class-newline
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8a33b8648b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-flake8-class-newline
+ pkgdesc = Flake lint for newline after class definitions.
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = https://github.com/AlexanderVanEck/flake8-class-newline
+ arch = any
+ license = MIT
+ depends = flake8
+ source = https://github.com/AlexanderVanEck/flake8-class-newline/archive/1.6.0.tar.gz
+ md5sums = abf91dad16b08ec69b13b12886550774
+
+pkgname = python-flake8-class-newline
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6fa8d94df51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: acxz <akashpatel2008@yahoo.com>
+
+pkgname="python-flake8-class-newline"
+_pkgname="flake8-class-newline"
+pkgver=1.6.0
+pkgrel=1
+pkgdesc="Flake lint for newline after class definitions."
+arch=('any')
+url="https://github.com/AlexanderVanEck/${_pkgname}"
+license=('MIT')
+depends=('flake8')
+source=("https://github.com/AlexanderVanEck/flake8-class-newline/archive/$pkgver.tar.gz")
+md5sums=('abf91dad16b08ec69b13b12886550774')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}