summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Labbe2018-07-26 11:35:48 -0400
committerAdam Labbe2018-07-26 11:35:48 -0400
commit21d0a6589ae15240938c60a0e15edf30e7655b6f (patch)
tree03140bd7d1604ce2e5b5aedb39b6bd122baf2c05
downloadaur-21d0a6589ae15240938c60a0e15edf30e7655b6f.tar.gz
Initial release of flake8-formatter-abspath
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD44
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a82f7626bab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-flake8-formatter-abspath
+ pkgdesc = A flake8 formatter plugin that shows the absolute path of files with warnings.
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://github.com/jarshwah/flake8_formatter_abspath
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ makedepends = git
+ source = git+https://github.com/jarshwah/flake8_formatter_abspath.git#tag=v1.0.1
+ md5sums = SKIP
+
+pkgname = python-flake8-formatter-abspath
+ depends = python-setuptools
+
+pkgname = python2-flake8-formatter-abspath
+ depends = python2-setuptools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4072fff50ed6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# $Id$
+# Maintainer: Adam Labbe <adamlabbe@gmail.com>
+
+pkgbase=python-flake8-formatter-abspath
+pkgname=('python-flake8-formatter-abspath' 'python2-flake8-formatter-abspath')
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='A flake8 formatter plugin that shows the absolute path of files with warnings.'
+arch=('any')
+license=('MIT')
+url='https://github.com/jarshwah/flake8_formatter_abspath'
+makedepends=('python-setuptools' 'python2-setuptools' 'git')
+source=("git+https://github.com/jarshwah/flake8_formatter_abspath.git#tag=v$pkgver")
+md5sums=('SKIP')
+
+prepare() {
+ cp -a flake8_formatter_abspath{,-py2}
+}
+
+build() {
+ cd "$srcdir"/flake8_formatter_abspath
+ python setup.py build
+
+ cd "$srcdir"/flake8_formatter_abspath-py2
+ python2 setup.py build
+}
+
+package_python-flake8-formatter-abspath() {
+ depends=('python-setuptools')
+
+ cd "$srcdir"/flake8_formatter_abspath
+ python setup.py install --root="$pkgdir"/ --optimize=1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-flake8-formatter-abspath() {
+ depends=('python2-setuptools')
+
+ cd "$srcdir"/flake8_formatter_abspath-py2
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+# vim:set ts=2 sw=2 et: