summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrodokk2022-04-25 10:43:21 +0200
committerbrodokk2022-04-25 10:43:21 +0200
commit1d98d33836f85942e8d733b6c16cf45f97d76d44 (patch)
tree61b1e78c89818b1cb32341f1da303f44627280c0
parent6655daa81d6cac31c8d9bc68cce987f651672432 (diff)
downloadaur-1d98d33836f85942e8d733b6c16cf45f97d76d44.tar.gz
Update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68b5c55880c3..49bc26e8e0f5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = python-flake8-print
pkgdesc = Check for Print statements in python files.
- pkgver = 3.1.4
+ pkgver = 4.0.0
pkgrel = 1
url = https://github.com/jbkahn/flake8-print
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
- source = https://github.com/JBKahn/flake8-print/archive/3.1.4.tar.gz
- sha512sums = f5caf02478c1bd47df7f922b560de97be5dc103e61461dea5e84b20111761f259dd231fb8c53f45f921ac5b0b010daf0cd5cca6024eae8e33f434d301eaba6bb
+ source = https://github.com/JBKahn/flake8-print/archive/4.0.0.tar.gz
+ sha512sums = cb62bd5a68835c1b5439593259260da7f3ca0c28afe0306cae77d8527d7572b485ab09622b149d67a79671a7f20e9507d6f760a70fda3b48916032dd898f873e
pkgname = python-flake8-print
-
diff --git a/PKGBUILD b/PKGBUILD
index a95896483f13..35fd5a8543fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=flake8-print
pkgname=python-$_pkgname
-pkgver=3.1.4
+pkgver=4.0.0
pkgrel=1
pkgdesc="Check for Print statements in python files."
@@ -11,13 +11,19 @@ url='https://github.com/jbkahn/flake8-print'
arch=('any')
license=('MIT')
-depends=('python')
+depends=(python)
+makedepends=(python-build python-installer python-wheel)
source=("https://github.com/JBKahn/$_pkgname/archive/$pkgver.tar.gz")
-sha512sums=('f5caf02478c1bd47df7f922b560de97be5dc103e61461dea5e84b20111761f259dd231fb8c53f45f921ac5b0b010daf0cd5cca6024eae8e33f434d301eaba6bb')
+sha512sums=('cb62bd5a68835c1b5439593259260da7f3ca0c28afe0306cae77d8527d7572b485ab09622b149d67a79671a7f20e9507d6f760a70fda3b48916032dd898f873e')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}