summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2021-12-23 16:48:41 +0000
committerGeorge Rawlinson2021-12-23 16:48:41 +0000
commit9269f14a81070636dbd96cbb432592beeb52defc (patch)
treeef3bfb171a2b5d37e7f715102c3053d352e4008a
parent5b698a6175d1323198f7c864d28ee6a0ff26027f (diff)
downloadaur-9269f14a81070636dbd96cbb432592beeb52defc.tar.gz
upgpkg: python-flake8-pytest-style 1.6.0-1
* New upstream release. * Replace python-pip with python-install.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93841f367f06..b0cd060f3a4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = python-flake8-pytest-style
pkgdesc = A flake8 extension that checks issues with pytest tests
- pkgver = 1.5.1
- pkgrel = 2
+ pkgver = 1.6.0
+ pkgrel = 1
url = https://github.com/m-burst/flake8-pytest-style
arch = any
license = MIT
checkdepends = python-pytest-deadfixtures
makedepends = python-build
+ makedepends = python-install
makedepends = python-poetry-core
- makedepends = python-pip
depends = python
depends = flake8
depends = python-flake8-plugin-utils
- source = python-flake8-pytest-style-1.5.1.tar.gz::https://github.com/m-burst/flake8-pytest-style/archive/v1.5.1.tar.gz
- sha512sums = f961bf8d5c9391959dcb8615963937b824f11586de7c66306b4654e444ef28cb389966582b9daffb356747c58cae057964a7641204f58f3c6b2ede3af1deb1c3
- b2sums = 66fde40cb2f54954f2ca279c9dbedee1eb9942728ade58ea2943f698565b705cacd825e7002b3226d84deac5cf6a8ced1a54999fb1c6e24c2b9664053c1b2cf0
+ source = python-flake8-pytest-style-1.6.0.tar.gz::https://github.com/m-burst/flake8-pytest-style/archive/v1.6.0.tar.gz
+ sha512sums = 6d66d75b3e94974ea5a45e688ecc96b74f9a3187f0aefef542747e54d534a783093f08d165d01ba6ea6bdef07e45d3aeaeb9799945be38b7921c5e8e51ea5b30
+ b2sums = a14b01eb397de0c35dc55aaecdda661b271418538161f4955c0daffeceb89e4ba24fa8b16c7c4b856f10059172873b303a0c76ccf651459eaf58f4ecd683adb7
pkgname = python-flake8-pytest-style
diff --git a/PKGBUILD b/PKGBUILD
index af2238fab5d8..dba0afa5b67d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,26 @@
pkgname=python-flake8-pytest-style
_pkgname="${pkgname#python-}"
_name="${_pkgname/-/_}"
-pkgver=1.5.1
-pkgrel=2
+pkgver=1.6.0
+pkgrel=1
pkgdesc="A flake8 extension that checks issues with pytest tests"
arch=('any')
url="https://github.com/m-burst/flake8-pytest-style"
license=('MIT')
depends=('python' 'flake8' 'python-flake8-plugin-utils')
-makedepends=('python-build' 'python-poetry-core' 'python-pip')
+makedepends=('python-build' 'python-install' 'python-poetry-core')
checkdepends=('python-pytest-deadfixtures')
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha512sums=('f961bf8d5c9391959dcb8615963937b824f11586de7c66306b4654e444ef28cb389966582b9daffb356747c58cae057964a7641204f58f3c6b2ede3af1deb1c3')
-b2sums=('66fde40cb2f54954f2ca279c9dbedee1eb9942728ade58ea2943f698565b705cacd825e7002b3226d84deac5cf6a8ced1a54999fb1c6e24c2b9664053c1b2cf0')
+sha512sums=('6d66d75b3e94974ea5a45e688ecc96b74f9a3187f0aefef542747e54d534a783093f08d165d01ba6ea6bdef07e45d3aeaeb9799945be38b7921c5e8e51ea5b30')
+b2sums=('a14b01eb397de0c35dc55aaecdda661b271418538161f4955c0daffeceb89e4ba24fa8b16c7c4b856f10059172873b303a0c76ccf651459eaf58f4ecd683adb7')
build() {
cd "$_pkgname-$pkgver"
- python -m build --wheel --skip-dependency-check --no-isolation
+ python \
+ -m build \
+ --wheel \
+ --skip-dependency-check \
+ --no-isolation
}
check() {
@@ -28,12 +32,10 @@ check() {
package() {
cd "$_pkgname-$pkgver"
- PIP_CONFIG_FILE=/dev/null pip \
- install \
- --isolated \
- --root="$pkgdir" \
- --ignore-installed \
- --no-deps \
+
+ python -m install \
+ --optimize=1 \
+ --destdir="$pkgdir" \
dist/*.whl
install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE