summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-02-24 16:59:05 +1300
committerGeorge Rawlinson2023-02-24 16:59:05 +1300
commitf52cd21b645c570b35118658b84435bbf8b0e660 (patch)
tree7badbe581f473d7740ce5859de0e2e709a32378d
parent9269f14a81070636dbd96cbb432592beeb52defc (diff)
downloadaur-f52cd21b645c570b35118658b84435bbf8b0e660.tar.gz
upgpkg: python-flake8-pytest-style 1.7.2-1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD55
2 files changed, 35 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0cd060f3a4e..bf0123e20221 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = python-flake8-pytest-style
pkgdesc = A flake8 extension that checks issues with pytest tests
- pkgver = 1.6.0
+ pkgver = 1.7.2
pkgrel = 1
url = https://github.com/m-burst/flake8-pytest-style
arch = any
license = MIT
- checkdepends = python-pytest-deadfixtures
+ makedepends = git
makedepends = python-build
- makedepends = python-install
+ makedepends = python-installer
makedepends = python-poetry-core
depends = python
depends = flake8
depends = python-flake8-plugin-utils
- source = python-flake8-pytest-style-1.6.0.tar.gz::https://github.com/m-burst/flake8-pytest-style/archive/v1.6.0.tar.gz
- sha512sums = 6d66d75b3e94974ea5a45e688ecc96b74f9a3187f0aefef542747e54d534a783093f08d165d01ba6ea6bdef07e45d3aeaeb9799945be38b7921c5e8e51ea5b30
- b2sums = a14b01eb397de0c35dc55aaecdda661b271418538161f4955c0daffeceb89e4ba24fa8b16c7c4b856f10059172873b303a0c76ccf651459eaf58f4ecd683adb7
+ source = python-flake8-pytest-style::git+https://github.com/m-burst/flake8-pytest-style#commit=01a4c8eaf64292363bcbae4c93bfdd6722a494ff
+ b2sums = SKIP
pkgname = python-flake8-pytest-style
diff --git a/PKGBUILD b/PKGBUILD
index dba0afa5b67d..cb24ae601fc8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,47 @@
# Maintainer: George Rawlinson <george@rawlinson.net.nz>
pkgname=python-flake8-pytest-style
-_pkgname="${pkgname#python-}"
-_name="${_pkgname/-/_}"
-pkgver=1.6.0
+pkgver=1.7.2
pkgrel=1
-pkgdesc="A flake8 extension that checks issues with pytest tests"
+pkgdesc='A flake8 extension that checks issues with pytest tests'
arch=('any')
-url="https://github.com/m-burst/flake8-pytest-style"
+url='https://github.com/m-burst/flake8-pytest-style'
license=('MIT')
depends=('python' 'flake8' 'python-flake8-plugin-utils')
-makedepends=('python-build' 'python-install' 'python-poetry-core')
-checkdepends=('python-pytest-deadfixtures')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha512sums=('6d66d75b3e94974ea5a45e688ecc96b74f9a3187f0aefef542747e54d534a783093f08d165d01ba6ea6bdef07e45d3aeaeb9799945be38b7921c5e8e51ea5b30')
-b2sums=('a14b01eb397de0c35dc55aaecdda661b271418538161f4955c0daffeceb89e4ba24fa8b16c7c4b856f10059172873b303a0c76ccf651459eaf58f4ecd683adb7')
+makedepends=(
+ 'git'
+ 'python-build'
+ 'python-installer'
+ 'python-poetry-core'
+)
+#checkdepends=('python-pytest-deadfixtures')
+_commit='01a4c8eaf64292363bcbae4c93bfdd6722a494ff'
+source=("$pkgname::git+$url#commit=$_commit")
+b2sums=('SKIP')
-build() {
- cd "$_pkgname-$pkgver"
- python \
- -m build \
- --wheel \
- --skip-dependency-check \
- --no-isolation
+pkgver() {
+ cd "$pkgname"
+
+ git describe --tags | sed 's/^v//'
}
-check() {
- cd "$_pkgname-$pkgver"
- pytest
+build() {
+ cd "$pkgname"
+
+ python -m build --wheel --no-isolation
}
+#check() {
+# cd "$pkgname"
+#
+# pytest -v
+#}
+
package() {
- cd "$_pkgname-$pkgver"
+ cd "$pkgname"
- python -m install \
- --optimize=1 \
- --destdir="$pkgdir" \
- dist/*.whl
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ # license
install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}