summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2020-06-09 09:25:23 +0200
committerneodarz2020-06-09 09:25:23 +0200
commit49fe467b48d49296950083b2cd9a9c07343c61f8 (patch)
treecd894b3a9fbf1992ff55658a50366fafbc858f51
downloadaur-49fe467b48d49296950083b2cd9a9c07343c61f8.tar.gz
Inital commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..344d325c358a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-flake8-rst-docstrings
+ pkgdesc = flake8 plugin to validate Python docstrings as reStructuredText (RST)
+ pkgver = 0.0.13
+ pkgrel = 1
+ url = https://github.com/peterjc/flake8-rst-docstrings
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/peterjc/flake8-rst-docstrings/archive/v0.0.13.tar.gz
+ sha512sums = aefa10f47f4815d7cb4106f1dc1914cc557796c738586c872103665d861f99d6bd8e076ef7fda64a6822a84230d88060f803b2bddd0b5c103e0562ee1211e83e
+
+pkgname = python-flake8-rst-docstrings
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24701dc88021
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+_pkgname=flake8-rst-docstrings
+pkgname=python-$_pkgname
+
+pkgver=0.0.13
+pkgrel=1
+pkgdesc="flake8 plugin to validate Python docstrings as reStructuredText (RST)"
+
+url='https://github.com/peterjc/flake8-rst-docstrings'
+arch=('any')
+license=('MIT')
+
+depends=('python')
+
+source=("https://github.com/peterjc/$_pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('aefa10f47f4815d7cb4106f1dc1914cc557796c738586c872103665d861f99d6bd8e076ef7fda64a6822a84230d88060f803b2bddd0b5c103e0562ee1211e83e')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+