summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrodokk2023-02-18 15:30:47 +0100
committerbrodokk2023-02-18 15:30:47 +0100
commit60c9033a278c5d26a78b2ce39ecdc928e9a9d56a (patch)
tree25eba3a5c6d6cd46600aeedc007cb1b2a1143858
parent7fffc37d9ac6db47f66689a9e10685cd9374a77b (diff)
downloadaur-60c9033a278c5d26a78b2ce39ecdc928e9a9d56a.tar.gz
Update to latest version
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd2d51477f4c..bd5ab151d8a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,16 @@
pkgbase = python-flake8-rst-docstrings
pkgdesc = flake8 plugin to validate Python docstrings as reStructuredText (RST)
- pkgver = 0.2.5
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/peterjc/flake8-rst-docstrings
arch = any
license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python
depends = python-restructuredtext_lint
- source = https://github.com/peterjc/flake8-rst-docstrings/archive/v0.2.5.tar.gz
- sha512sums = 7be16023db379e24fd6f13a3ae59add3e0f52f3df0c16c7ccd9cec44ac1b861fc85db7597409619ef628d27ddaf3702640edda9e9d9a8f6aade4c43c78b2ef69
+ source = https://github.com/peterjc/flake8-rst-docstrings/archive/v0.3.0.tar.gz
+ sha512sums = 30f4bc0eb2c3465fcf19333f0bd9feb7a4c6472faae7d4e7db9a380d530426a3aea34f6671f7442b9285a5a37b11fabbf00ae41d4260503449d51dc2039f549c
pkgname = python-flake8-rst-docstrings
diff --git a/PKGBUILD b/PKGBUILD
index 3c267bab0171..d177a61fd64f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=flake8-rst-docstrings
pkgname=python-$_pkgname
-pkgver=0.2.5
+pkgver=0.3.0
pkgrel=1
pkgdesc="flake8 plugin to validate Python docstrings as reStructuredText (RST)"
@@ -12,12 +12,17 @@ arch=('any')
license=('MIT')
depends=('python' 'python-restructuredtext_lint')
+makedepends=(python-build python-installer python-wheel)
source=("https://github.com/peterjc/$_pkgname/archive/v$pkgver.tar.gz")
-sha512sums=('7be16023db379e24fd6f13a3ae59add3e0f52f3df0c16c7ccd9cec44ac1b861fc85db7597409619ef628d27ddaf3702640edda9e9d9a8f6aade4c43c78b2ef69')
+sha512sums=('30f4bc0eb2c3465fcf19333f0bd9feb7a4c6472faae7d4e7db9a380d530426a3aea34f6671f7442b9285a5a37b11fabbf00ae41d4260503449d51dc2039f549c')
-package() {
+build() {
cd "$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m build --wheel --no-isolation
}
+package() {
+ cd "$_pkgname-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}