summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Room2021-05-07 14:08:47 +0100
committerAdrian Room2021-05-07 14:08:47 +0100
commit4f36fa0533e123fbab6f51ce62d4cd5d8c306370 (patch)
tree0123e9cd9494f070cfb88678832d100bcff9429c
downloadaur-4f36fa0533e123fbab6f51ce62d4cd5d8c306370.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..385e7a91a383
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-flake8-simplify
+ pkgdesc = A flake8 plugin that helps you simplify your code.
+ pkgver = 0.14.0
+ pkgrel = 1
+ url = https://github.com/MartinThoma/flake8-simplify/
+ arch = any
+ license = MIT
+ depends = flake8
+ depends = python-astor
+ source = https://github.com/MartinThoma/flake8-simplify/archive/0.14.0.tar.gz
+ md5sums = d165dcd870c9e8eceab12093793647df
+
+pkgname = python-flake8-simplify
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be1beefd2184
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Adrian Room <ingolemo@gmail.com>
+
+pkgname="python-flake8-simplify"
+_pkgname="flake8-simplify"
+pkgver=0.14.0
+pkgrel=1
+pkgdesc="A flake8 plugin that helps you simplify your code."
+arch=('any')
+url="https://github.com/MartinThoma/flake8-simplify/"
+license=('MIT')
+depends=('flake8' 'python-astor')
+source=("https://github.com/MartinThoma/flake8-simplify/archive/$pkgver.tar.gz")
+md5sums=('d165dcd870c9e8eceab12093793647df')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}