summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneodarz2020-06-04 18:03:41 +0200
committerneodarz2020-06-04 18:03:41 +0200
commitbb7ea888496c926c7481e1bdaa104ea8f7cac997 (patch)
treec2ab4bc71c09cee133da56ff5859e95798bee93a
downloadaur-bb7ea888496c926c7481e1bdaa104ea8f7cac997.tar.gz
Inital commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5f247145ae92
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-flake8-variables-names
+ pkgdesc = A flake8 extension that helps to make more readable variables names
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/best-doctor/flake8-variables-names
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/best-doctor/flake8-variables-names/archive/v0.0.2.tar.gz
+ sha512sums = c59938076df1b8d4686511b76e402f7d13531cbb1ecb47d856535210e1b2d04ff6549ec4621d09927ca0f4a358bea381a6303714fa298f808811f70ccb1734ee
+
+pkgname = python-flake8-variables-names
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a3afe0462e7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: neodarz <neodarz at neodarz dot net>
+
+_pkgname=flake8-variables-names
+pkgname=python-$_pkgname
+
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="A flake8 extension that helps to make more readable variables names"
+
+url='https://github.com/best-doctor/flake8-variables-names'
+arch=('any')
+license=('MIT')
+
+depends=('python')
+
+source=("https://github.com/best-doctor/$_pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('c59938076df1b8d4686511b76e402f7d13531cbb1ecb47d856535210e1b2d04ff6549ec4621d09927ca0f4a358bea381a6303714fa298f808811f70ccb1734ee')
+
+package() {
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+