summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDylan Whichard2016-03-12 22:14:00 -0500
committerDylan Whichard2016-03-12 22:14:00 -0500
commitb0934fc1642e741ba343e1876496c3ec6e171766 (patch)
tree1dd649aab988824a360168c1daefd2e2889adbb4
downloadaur-python-flask-aiohttp-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48f03f26909c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Mar 13 03:11:26 UTC 2016
+pkgbase = python-flask-aiohttp-git
+ pkgdesc = Asynchronous Flask using aiohttp.
+ pkgver = 7.a1aaa68
+ pkgrel = 1
+ url = https://github.com/dylwhich/Flask-aiohttp
+ arch = any
+ license = MIT
+ depends = python>=3.4
+ depends = python-aiohttp>=0.15
+ depends = python-flask>=0.10.0
+ provides = python-flask-aiohttp
+ conflicts = python-flask-aiohttp
+ options = !emptydirs
+ source = git+https://github.com/$_owner/$_name.git
+ sha256sums = SKIP
+
+pkgname = python-flask-aiohttp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d7fc767302c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Dylan Whichard <dylan at whichard dot com>
+_name=Flask-aiohttp
+_owner=dylwhich
+pkgname=python-flask-aiohttp-git
+pkgver=8.152e71e
+pkgrel=1
+pkgdesc="Asynchronous Flask using aiohttp."
+arch=('any')
+url="https://github.com/$_owner/$_name"
+license=('MIT')
+depends=('python>=3.4' 'python-aiohttp>=0.15' 'python-flask>=0.10.0')
+provides=('python-flask-aiohttp')
+conflicts=('python-flask-aiohttp')
+options=(!emptydirs)
+source=("git+https://github.com/$_owner/$_name.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_name"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd "$srcdir/$_name"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: