summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2020-01-10 23:48:27 +0000
committerAntonio Rojas2020-01-10 23:48:27 +0000
commitab2b32b4370070c48d0ad7160a8c32b1fac1d5b6 (patch)
treebba8788f5812e4bc2d18d29e70f4fc63a2f1d820
downloadaur-ab2b32b4370070c48d0ad7160a8c32b1fac1d5b6.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7ec69ac2f65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-flask-autoindex
+ pkgdesc = Flask-AutoIndex generates an index page for your Flask application automatically
+ pkgver = 0.6.4
+ pkgrel = 2
+ url = https://packages.python.org/Flask-AutoIndex/
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-flask-silk
+ depends = python-future
+ source = python-flask-autoindex-0.6.4.tar.gz::https://github.com/general03/flask-autoindex/archive/v0.6.4.tar.gz
+ sha256sums = 44df9cc770d7fc30f8e90d77c468035329855b90aaff18bf4c2a7dc5fac63b77
+
+pkgname = python-flask-autoindex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74b5bd6e1141
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Maintainer: Moritz Lipp <mlq@pwmt.org>
+
+_pipname=flask-autoindex
+pkgname=python-flask-autoindex
+pkgver=0.6.4
+pkgrel=2
+pkgdesc="Flask-AutoIndex generates an index page for your Flask application automatically"
+arch=(any)
+url="https://packages.python.org/Flask-AutoIndex/"
+license=(BSD)
+depends=(python-flask-silk python-future)
+makedepends=(python-setuptools)
+source=($pkgname-$pkgver.tar.gz::"https://github.com/general03/flask-autoindex/archive/v$pkgver.tar.gz")
+sha256sums=('44df9cc770d7fc30f8e90d77c468035329855b90aaff18bf4c2a7dc5fac63b77')
+
+package() {
+ cd $_pipname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
+ install -m644 LICENSE.md "$pkgdir"/usr/share/licenses/$pkgname
+}