summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSean Enck2017-03-09 15:27:03 -0500
committerSean Enck2017-03-09 15:27:03 -0500
commit89f6e9ce0dd5c0feb6e315210200fc1c99a45172 (patch)
treefd65ae6853b98ba0d7ec162beb21fa1be34c7398
parent538027843d58c368e04f1a9142b3e5e5cc01631d (diff)
downloadaur-89f6e9ce0dd5c0feb6e315210200fc1c99a45172.tar.gz
updated for latest requirements and github url
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8514cde3b0e..9362c532debc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = python-flask-git
pkgdesc = Micro webdevelopment framework for Python
- pkgver = 0.10.1.r682.ge99fec2
- pkgrel = 1
+ pkgver = 0.12.r46.g7a5e8ef3
+ pkgrel = 2
url = http://flask.pocoo.org/
arch = any
license = custom:BSD
makedepends = git
depends = python-werkzeug
depends = python-jinja
- depends = python-itsdangerous
+ depends = python-itsdangerous,
+ depends = python-click
provides = python-flask
conflicts = python-flask
- source = git://github.com/mitsuhiko/flask.git
+ source = git://github.com/pallets/flask.git
md5sums = SKIP
pkgname = python-flask-git
diff --git a/PKGBUILD b/PKGBUILD
index 5f912d87f63e..05fa36c348d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
+# Maintainer: Sean Enck <enckse@gmail.com>
pkgname=python-flask-git
_pkgname=flask
-pkgver=0.10.1.r682.ge99fec2
+pkgver=0.12.r46.g7a5e8ef3
pkgrel=1
pkgdesc='Micro webdevelopment framework for Python'
arch=('any')
url='http://flask.pocoo.org/'
license=('custom:BSD')
-depends=('python-werkzeug' 'python-jinja' 'python-itsdangerous')
+depends=('python-werkzeug' 'python-jinja' 'python-itsdangerous', 'python-click')
makedepends=('git')
conflicts=('python-flask')
provides=('python-flask')
-source=('git://github.com/mitsuhiko/flask.git')
+source=('git://github.com/pallets/flask.git')
md5sums=('SKIP')
pkgver() {
@@ -20,14 +21,11 @@ pkgver() {
build() {
cd $_pkgname
-
python setup.py build
}
package() {
cd $_pkgname
-
python setup.py install --root=${pkgdir} --optimize=1
-
install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/python-flask
}