summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRiccardo Berto2017-10-05 18:43:04 +0200
committerRiccardo Berto2017-10-05 18:43:04 +0200
commit634ae473d77f9ffc4dadb3b64832eb787b5d2183 (patch)
tree50a12dc9c7d2bd9a0ffeaa34035787d4469c449d
downloadaur-634ae473d77f9ffc4dadb3b64832eb787b5d2183.tar.gz
First commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb6cc9c74204
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-flask-paginate
+ pkgdesc = flask-paginate is a simple paginate extension for flask which is reference to will_paginate, and use bootstrap as css framework.
+ pkgver = 0.5.1
+ pkgrel = 1
+ url = http://github.com/lixxu/flask-paginate
+ arch = any
+ license = BSD-3
+ makedepends = python-setuptools
+ source = https://pypi.python.org/packages/fc/95/d7d61640893050a55365ffba33885883495c0838a05f11984336aa023f00/flask-paginate-0.5.1.tar.gz#md5=83bdaa64c75df75296abb5a4f7edfa14
+ md5sums = 83bdaa64c75df75296abb5a4f7edfa14
+
+pkgname = python-flask-paginate
+ depends = python-flask
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb205b37363e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: RcrdBrt <riccardobrt@gmail.com>
+# Prev maintainer: ser
+
+_pkgname=flask-paginate
+pkgname=python-flask-paginate
+pkgver=0.5.1
+pkgrel=1
+pkgdesc="flask-paginate is a simple paginate extension for flask which is reference to will_paginate, and use bootstrap as css framework."
+arch=('any')
+url="http://github.com/lixxu/flask-paginate"
+license=('BSD-3')
+makedepends=('python-setuptools')
+source=("https://pypi.python.org/packages/fc/95/d7d61640893050a55365ffba33885883495c0838a05f11984336aa023f00/flask-paginate-0.5.1.tar.gz#md5=83bdaa64c75df75296abb5a4f7edfa14")
+md5sums=('83bdaa64c75df75296abb5a4f7edfa14')
+
+package() {
+depends=('python-flask')
+
+ cd $_pkgname-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+}
+