summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVojtech Kral2016-01-09 18:03:08 +0100
committerVojtech Kral2016-01-09 18:03:30 +0100
commit1195170444224b215debfdbc08c0f02424c99191 (patch)
tree27672148cac93c9292c90628b03193b6dc01e03b
downloadaur-1195170444224b215debfdbc08c0f02424c99191.tar.gz
Initial
-rw-r--r--.SRCINFO24
-rw-r--r--LICENSE24
-rw-r--r--PKGBUILD53
3 files changed, 101 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81ca8eb4fd40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sat Jan 9 17:03:30 UTC 2016
+pkgbase = python-flask-pymongo
+ pkgdesc = Flask-PyMongo bridges Flask and PyMongo, so that you can use Flask’s normal mechanisms to configure and connect to MongoDB.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://flask-pymongo.readthedocs.org/en/latest/
+ arch = any
+ license = BSD
+ makedepends = python-distribute
+ makedepends = python2-distribute
+ source = https://pypi.python.org/packages/source/F/Flask-PyMongo/Flask-PyMongo-0.4.0.tar.gz
+ source = LICENSE
+ sha256sums = 707ddff92f5b7bdc34d401f1f3857a3d1a9f5dba76e6a1422ccbc3651e2ca521
+ sha256sums = afa271f992bd7a47170804144a9b1f923a18ea91592c2945c4e9e4b9d025fe54
+
+pkgname = python-flask-pymongo
+ depends = python-flask>=0.8
+ depends = python-pymongo>=2.4
+
+pkgname = python2-flask-pymongo
+ depends = python2-flask>=0.8
+ depends = python2-pymongo>=2.4
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..754f84a4e0af
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,24 @@
+Copyright (c) 2011-2015, Dan Crosta
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are met:
+
+* Redistributions of source code must retain the above copyright notice,
+ this list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above copyright notice,
+ this list of conditions and the following disclaimer in the documentation
+ and/or other materials provided with the distribution.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e48ac4b334f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Vojtech Kral <vojtech_kral^hk>
+
+pkgbase=python-flask-pymongo
+pkgname=('python-flask-pymongo' 'python2-flask-pymongo')
+_realname=Flask-PyMongo
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Flask-PyMongo bridges Flask and PyMongo, so that you can use Flask’s normal mechanisms to configure and connect to MongoDB.'
+_baseurl='https://pypi.python.org'
+url="https://flask-pymongo.readthedocs.org/en/latest/"
+arch=('any')
+license=('BSD')
+makedepends=('python-distribute' 'python2-distribute')
+source=("${_baseurl}/packages/source/F/${_realname}/${_realname}-${pkgver}.tar.gz"
+ 'LICENSE')
+sha256sums=('707ddff92f5b7bdc34d401f1f3857a3d1a9f5dba76e6a1422ccbc3651e2ca521'
+ 'afa271f992bd7a47170804144a9b1f923a18ea91592c2945c4e9e4b9d025fe54')
+
+prepare() {
+ # We ship separated python{,2}-packaging packages.
+ cp -a ${_realname}-${pkgver}{,-python2}
+}
+
+build() {
+ # Build python 3 module
+ cd "${srcdir}/${_realname}-${pkgver}"
+ python3 setup.py build
+
+ # Build python 2 module
+ cd "${srcdir}/${_realname}-${pkgver}-python2"
+ python2 setup.py build
+}
+
+package_python-flask-pymongo() {
+ depends=('python-flask>=0.8' 'python-pymongo>=2.4')
+
+ cd "${srcdir}/${_realname}-${pkgver}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+
+ _licenses_path="${pkgdir}/usr/share/licenses/python-flask-pymongo"
+ install -D -m644 ${srcdir}/LICENSE "${_licenses_path}/LICENSE"
+}
+
+package_python2-flask-pymongo() {
+ depends=('python2-flask>=0.8' 'python2-pymongo>=2.4')
+
+ cd "${srcdir}/${_realname}-${pkgver}-python2"
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+
+ _licenses_path="${pkgdir}/usr/share/licenses/python2-flask-pymongo"
+ install -D -m644 ${srcdir}/LICENSE "${_licenses_path}/LICENSE"
+}
+