summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Giovannetti2019-02-10 01:55:59 +0800
committerDario Giovannetti2019-02-10 01:55:59 +0800
commitfd3a71b6db9f78101d5c15dbde3c272a2a86d94a (patch)
tree227d19b83961cd81273a5a561506d9d14ff1766a
parentebe0ab715a305a3def6108fd3801a952a9efca09 (diff)
downloadaur-fd3a71b6db9f78101d5c15dbde3c272a2a86d94a.tar.gz
v1.3.0
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD7
3 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89c47e5c5226..0287788cb5a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = python-flask-restinpeace
pkgdesc = Create Flask REST APIs in peace.
- pkgver = 1.2.1
- pkgrel = 2
+ pkgver = 1.3.0
+ pkgrel = 1
url = https://github.com/kynikos/lib.py.flask-rip
arch = any
license = MIT
makedepends = python-setuptools
depends = python-flask-marshmallow
depends = python-apispec
+ depends = python-apispec-webframeworks
depends = python-yaml
- source = https://files.pythonhosted.org/packages/source/f/flask-restinpeace/flask-restinpeace-1.2.1.tar.gz
- sha256sums = 4c585d271c270dfad1848c0fe157ff8b7d75dce4291414c817607219d0ea92c7
+ source = https://files.pythonhosted.org/packages/source/f/flask-restinpeace/flask-restinpeace-1.3.0.tar.gz
+ sha256sums = 8736202546ab649116298912693839d68c3c8f639b5acb0c230e6aefd5ba4e19
pkgname = python-flask-restinpeace
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e9648f0f4308
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
index e142303f0230..782ad32ae2f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,22 @@
_name='flask-restinpeace'
pkgname="python-${_name}"
-pkgver='1.2.1'
-pkgrel=2
+pkgver='1.3.0'
+pkgrel=1
pkgdesc="Create Flask REST APIs in peace."
arch=('any')
url="https://github.com/kynikos/lib.py.flask-rip"
license=('MIT')
depends=('python-flask-marshmallow'
'python-apispec'
+ 'python-apispec-webframeworks'
# python-yaml is a python-apispec optdepend, but it seems required
# to use this module?
# TODO: Report a bug?
'python-yaml')
makedepends=('python-setuptools')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('4c585d271c270dfad1848c0fe157ff8b7d75dce4291414c817607219d0ea92c7')
+sha256sums=('8736202546ab649116298912693839d68c3c8f639b5acb0c230e6aefd5ba4e19')
package() {
cd "${srcdir}/${_name}-${pkgver}"