summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2021-07-04 19:18:26 +0000
committerJelle van der Waa2021-07-04 19:18:26 +0000
commitb841bec7cbd88c02717a20522c568a566ffbeb4f (patch)
tree51a18d7b04257e85eb9ee71a86a112f3e977e8a6
parent8ea11ce675dfa0f9d3657716590c1c279428716d (diff)
downloadaur-b841bec7cbd88c02717a20522c568a566ffbeb4f.tar.gz
Add missing python-email-validator dependency
Add python-pytest-runner to the makedepends as otherwise the build errors out with a pip error.
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 481697b23210..a4014b045206 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,17 @@
_pkgname=flask-security
pkgname=python-flask-security
pkgver=3.0.0
-pkgrel=4
+pkgrel=5
pkgdesc='Quick and simple security for Flask applications'
url='https://github.com/mattupstate/flask-security'
arch=('any')
license=('MIT')
depends=('python' 'python-flask' 'python-flask-login' 'python-flask-mail' 'python-flask-principal'
- 'python-flask-wtf' 'python-flask-babelex' 'python-itsdangerous' 'python-passlib')
+ 'python-flask-wtf' 'python-flask-babelex' 'python-itsdangerous' 'python-passlib'
+ 'python-email-validator')
makedepends=('python-flask' 'python-flask-login' 'python-flask-mail' 'python-flask-principal'
'python-flask-wtf' 'python-flask-babelex' 'python-itsdangerous' 'python-passlib'
- 'python-sphinx' 'python-setuptools')
+ 'python-sphinx' 'python-setuptools' 'python-pytest-runner')
#checkdepends=('python-pytest' 'python-pytest-runner' 'python-pytest-cov' 'python-pytest-cache'
#'python-mock' 'python-sqlalchemy' 'python-flask-sqlalchemy' 'python-bcrypt' 'python-pony')
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/mattupstate/flask-security/archive/${pkgver}.tar.gz)