summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-06-30 21:08:11 +0200
committerM0Rf302019-06-30 21:08:11 +0200
commit76e029a222aed05e82c91b53783afdbd8425fc22 (patch)
treebaa3e36e280774d372722c16fbfac7934874ffb3
downloadaur-76e029a222aed05e82c91b53783afdbd8425fc22.tar.gz
python-flask-themes2: first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b59f041fa527
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-flask-themes2
+ pkgdesc = Easily theme your Flask app
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/sysr-q/flask-themes2
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-flask
+ source = https://github.com/sysr-q/flask-themes2/archive/0.1.3.tar.gz
+ md5sums = 4bcea481a74b4f3b125df63ff9b27b1f
+
+pkgname = python-flask-themes2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4732b4853ba8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: robertfoster
+
+pkgname='python-flask-themes2'
+pkgver=0.1.3
+pkgrel=1
+pkgdesc="Easily theme your Flask app"
+url="https://github.com/sysr-q/flask-themes2"
+license=('MIT')
+arch=('any')
+depends=('python' 'python-flask')
+makedepends=('python-setuptools')
+source=("https://github.com/sysr-q/flask-themes2/archive/$pkgver.tar.gz")
+
+build() {
+ cd $srcdir/${pkgname##python-}-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd ${srcdir}/${pkgname##python-}-$pkgver
+ python setup.py install --root=$pkgdir
+}
+
+md5sums=('4bcea481a74b4f3b125df63ff9b27b1f')