summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSerge Victor2015-07-28 20:21:12 +0700
committerSerge Victor2015-07-28 20:21:12 +0700
commit62d477c39c248e5d6eafd6bf0fcf97ac5dfc8e0d (patch)
treeb3db093876a7f4edc478d4eac7628958ceaf508f
downloadaur-62d477c39c248e5d6eafd6bf0fcf97ac5dfc8e0d.tar.gz
- split package as new in Arch.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD40
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fcc795abb9df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-flask-wtf
+ pkgdesc = Simple integration of Flask and WTForms
+ pkgver = 0.12
+ pkgrel = 1
+ url = https://pythonhosted.org/Flask-WTF/
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ makedepends = python-setuptools
+ source = https://pypi.python.org/packages/source/F/Flask-WTF/Flask-WTF-0.12.tar.gz
+ md5sums = c53a74e8ba481bf53405fd5efdf0339e
+
+pkgname = python2-flask-wtf
+ depends = python2-flask
+ depends = python2-wtforms
+
+pkgname = python-flask-wtf
+ depends = python-flask
+ depends = python-wtforms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4341ac089a00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# First Linux Arch packager: Serge Victor <arch@random.re>
+
+_pipname=Flask-WTF
+pkgbase=python-flask-wtf
+pkgname=('python2-flask-wtf' 'python-flask-wtf')
+pkgver=0.12
+pkgrel=1
+pkgdesc="Simple integration of Flask and WTForms"
+arch=('any')
+url="https://pythonhosted.org/Flask-WTF/"
+license=('BSD')
+makedepends=('python2-setuptools' 'python-setuptools')
+source=("https://pypi.python.org/packages/source/${_pipname:0:1}/$_pipname/$_pipname-$pkgver.tar.gz")
+md5sums=('c53a74e8ba481bf53405fd5efdf0339e')
+
+
+prepare() {
+ cp -R $_pipname-$pkgver python2-$_pipname-$pkgver
+}
+
+package_python2-flask-wtf() {
+depends=('python2-flask' 'python2-wtforms')
+
+ cd python2-$_pipname-$pkgver
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
+ install -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname
+}
+
+package_python-flask-wtf() {
+depends=('python-flask' 'python-wtforms')
+
+ cd $_pipname-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
+ install -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname
+}
+