diff options
author | Patrick Northon | 2024-07-09 16:55:16 -0400 |
---|---|---|
committer | Patrick Northon | 2024-07-09 16:55:16 -0400 |
commit | a043a743eda534ed4c54f0c74f96e310bc65d893 (patch) | |
tree | 8fed9beac0eccda3fbb61c477bfa4a4474c14b4a | |
parent | 7fe1c213f6edbe9c58911a8e3810b9c56e3f9a78 (diff) | |
download | aur-a043a743eda534ed4c54f0c74f96e310bc65d893.tar.gz |
Fix rpath.
-rw-r--r-- | .SRCINFO | 3 | ||||
-rw-r--r-- | PKGBUILD | 12 |
2 files changed, 12 insertions, 3 deletions
@@ -1,7 +1,7 @@ pkgbase = python-flet pkgdesc = Easily build realtime web, mobile and desktop apps in your favorite language and securely share them with your team. pkgver = 0.23.2 - pkgrel = 1 + pkgrel = 2 url = https://flet.dev/ arch = x86_64 license = Apache @@ -12,6 +12,7 @@ pkgbase = python-flet makedepends = go makedepends = flutter-engine makedepends = git + makedepends = patchelf depends = python-repath depends = python-websocket-client depends = python-watchdog @@ -3,7 +3,7 @@ _pkgname=flet pkgname=python-${_pkgname} pkgver=0.23.2 -pkgrel=1 +pkgrel=2 pkgdesc='Easily build realtime web, mobile and desktop apps in your favorite language and securely share them with your team.' url="https://${_pkgname}.dev/" license=('Apache') @@ -28,7 +28,8 @@ makedepends=( 'python-wheel' 'go' 'flutter-engine' - 'git') + 'git' + 'patchelf') arch=('x86_64') source=( "${_pkgname}-${pkgver}.tar.gz::https://github.com/${_pkgname}-dev/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz" @@ -90,6 +91,13 @@ package() { cp -r "client/build/linux/x64/release/bundle/"* "$pkgdir/${_client_installdir}" ln -s "/${_client_installdir}/flet" "$pkgdir/usr/bin/flet_view" + # Fix runpath + patchelf --set-rpath '$ORIGIN/lib' "$pkgdir/opt/$pkgname/$_pkgname" + for i in "$pkgdir/opt/$pkgname/lib"/*.so; do + [ -z "$(patchelf --print-rpath "$i")" ] && continue + patchelf --set-rpath '$ORIGIN' "$i" + done + #install -dm0755 "$pkgdir/usr/share/$pkgname" #cp -r 'client/build/web' "$pkgdir/usr/share/$pkgname" |