summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2025-02-26 20:05:56 -0500
committerPatrick Northon2025-02-26 20:05:56 -0500
commitad84edd271ff7e3b67de09f19d92e56fbd6d2134 (patch)
tree67270986bf8fa92514ec20ca5824ac1d775f2cee
parente1369b4643200797bef1bed869ace10fd6bf37ea (diff)
downloadaur-ad84edd271ff7e3b67de09f19d92e56fbd6d2134.tar.gz
Update version.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
-rw-r--r--flet-linux.patch12
3 files changed, 21 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7e4ec18220db..143f3fc03d92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-flet
pkgdesc = Easily build realtime web, mobile and desktop apps in your favorite language and securely share them with your team.
- pkgver = 0.25.2
+ pkgver = 0.27.2
pkgrel = 1
url = https://flet.dev/
arch = x86_64
- license = Apache
+ license = Apache-2.0
makedepends = goreleaser
makedepends = python-build
makedepends = python-installer
@@ -26,9 +26,9 @@ pkgbase = python-flet
depends = gstreamer
depends = gst-plugins-base-libs
depends = mpv
- source = flet-0.25.2.tar.gz::https://github.com/flet-dev/flet/archive/refs/tags/v0.25.2.tar.gz
+ source = flet-0.27.2.tar.gz::https://github.com/flet-dev/flet/archive/refs/tags/v0.27.2.tar.gz
source = flet-linux.patch
- sha256sums = 6980546511b1816908dceb9a56e39091e101dd9b21eddd3539fc08c257b69b50
- sha256sums = 2d7372f0a8a6f7ccbeb3f91a4c866cce002da39d3326b1f9ceab2b2162bf8e7c
+ sha256sums = c0a235f44d037ea203d05ddf76b201e353ca909c76f4ca5eb49253b35070c4b9
+ sha256sums = e252e4eec325886d76dfc54c90604ea81ec0d6791b7e22bb93f63cec6378c50c
pkgname = python-flet
diff --git a/PKGBUILD b/PKGBUILD
index e232eb9969ee..32b484a9785a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,11 @@
_pkgname=flet
pkgname=python-${_pkgname}
-pkgver=0.25.2
+pkgver=0.27.2
pkgrel=1
pkgdesc='Easily build realtime web, mobile and desktop apps in your favorite language and securely share them with your team.'
url="https://${_pkgname}.dev/"
-license=('Apache')
+license=('Apache-2.0')
depends=(
'python-repath'
'python-websocket-client'
@@ -36,11 +36,11 @@ arch=('x86_64')
source=(
"${_pkgname}-${pkgver}.tar.gz::https://github.com/${_pkgname}-dev/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz"
'flet-linux.patch')
-sha256sums=('6980546511b1816908dceb9a56e39091e101dd9b21eddd3539fc08c257b69b50'
- '2d7372f0a8a6f7ccbeb3f91a4c866cce002da39d3326b1f9ceab2b2162bf8e7c')
+sha256sums=('c0a235f44d037ea203d05ddf76b201e353ca909c76f4ca5eb49253b35070c4b9'
+ 'e252e4eec325886d76dfc54c90604ea81ec0d6791b7e22bb93f63cec6378c50c')
_srcdir="${_pkgname}-${pkgver}"
-_engine_version=3.24.5
+_engine_version=3.27.4
prepare() {
cd "${_srcdir}"
@@ -61,9 +61,8 @@ build() {
fvm flutter build linux --release
popd
- pushd 'server'
- APPVEYOR_BUILD_VERSION=${pkgver} goreleaser build --clean --snapshot --single-target
- popd
+ #cd 'sdk/python'
+ #python -m build --wheel --no-isolation
for dir in 'sdk/python/packages/'{flet-cli,flet-desktop,flet}; do
pushd "$dir"
@@ -77,6 +76,9 @@ package() {
install -Dm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${_pkgname}"
+ #pushd 'sdk/python'
+ # python -m installer --destdir="$pkgdir" 'dist/'*.whl
+ #popd
for dir in 'sdk/python/packages/'{flet-cli,flet-desktop,flet}; do
pushd "$dir"
python -m installer --destdir="$pkgdir" 'dist/'*.whl
@@ -98,11 +100,8 @@ package() {
#install -dm0755 "$pkgdir/usr/share/$pkgname"
#cp -r 'client/build/web' "$pkgdir/usr/share/$pkgname"
- install -Dm0755 "server/dist/fletd_"*'/fletd' -t "${pkgdir}/usr/bin"
-
cd "$pkgdir/usr/lib/python"*
install -dm0755 'site-packages/flet/bin'
- ln -s '/usr/bin/fletd' 'site-packages/flet/bin/fletd'
#ln -s "/usr/share/$pkgname/web" 'site-packages/flet/web'
local site_packages="$(python -c "import site; print(site.getsitepackages()[0])")"
diff --git a/flet-linux.patch b/flet-linux.patch
index 8b5bd3577bad..52eceb031b56 100644
--- a/flet-linux.patch
+++ b/flet-linux.patch
@@ -1,14 +1,14 @@
diff --git a/sdk/python/packages/flet-desktop/src/flet_desktop/__init__.py b/sdk/python/packages/flet-desktop/src/flet_desktop/__init__.py
-index ae1474c..990387b 100644
+index ddc100df..2b43e1e6 100644
--- a/sdk/python/packages/flet-desktop/src/flet_desktop/__init__.py
+++ b/sdk/python/packages/flet-desktop/src/flet_desktop/__init__.py
-@@ -673,6 +673,9 @@ def __locate_and_unpack_flet_view(page_url, assets_dir, hidden):
- app_path = temp_flet_dir.joinpath(app_name)
+@@ -151,6 +151,9 @@ def __locate_and_unpack_flet_view(page_url, assets_dir, hidden):
+ app_path = temp_flet_dir.joinpath(app_name)
args = ["open", str(app_path), "-n", "-W", "--args", page_url, pid_file]
elif is_linux():
+ app_path = "/usr/bin/flet_view"
+ args = [str(app_path), page_url, pid_file]
+ elif 0:
- # build version-specific path to flet folder
- temp_flet_dir = Path.home().joinpath(".flet", "bin", f"flet-{version.version}")
-
+ app_path = None
+ # try loading Flet client built with the latest run of `flet build`
+ build_linux = os.path.join(os.getcwd(), "build", "linux")