summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-12-03 09:03:29 +1300
committercaltlgin2020-12-03 09:03:29 +1300
commit4955e9de496423d0f132a9c4b02e252452d7bd45 (patch)
tree334377b14466f28aa41925f2d928e1cb80b38ba0
parentfc5c975c94d0fc00f5fac09ec5b0bf9a2fd76fd0 (diff)
downloadaur-4955e9de496423d0f132a9c4b02e252452d7bd45.tar.gz
Python 3.9 rebuild
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD11
3 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 158824d43eab..207585053340 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = python-flexx
pkgdesc = Write desktop and web apps in pure Python
pkgver = 0.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/flexxui/flexx
arch = any
license = BSD
makedepends = python-setuptools
- depends = python
depends = python-dialite
depends = python-pscript
depends = python-tornado
depends = python-webruntime
- provides = flexx
source = https://files.pythonhosted.org/packages/source/f/flexx/flexx-0.8.1.tar.gz
sha256sums = a691f1f950efef17c37831a994c7e09c6fc24573b95a45439c2c8d1b6c765388
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 96192f9f42e5..2e701df5d0ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,17 @@
_pkgname='flexx'
pkgname="python-${_pkgname}"
pkgver=0.8.1
-pkgrel=1
+pkgrel=2
pkgdesc='Write desktop and web apps in pure Python'
arch=('any')
url='https://github.com/flexxui/flexx'
+_url_pypi='https://pypi.org/project/flexx'
license=('BSD')
-depends=('python'
- 'python-dialite'
+depends=('python-dialite'
'python-pscript'
'python-tornado'
'python-webruntime')
makedepends=('python-setuptools')
-provides=("${_pkgname}")
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('a691f1f950efef17c37831a994c7e09c6fc24573b95a45439c2c8d1b6c765388')
@@ -27,8 +26,8 @@ build() {
package() {
cd "${_pkgname}-${pkgver}"
python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.md'
- install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
+ install -Dvm644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim: ts=2 sw=2 et: