summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRonuk Raval2019-05-05 17:59:34 -0400
committerRonuk Raval2019-05-05 17:59:34 -0400
commit7ef8fd23b4df883a3a56e673b530e9cf4f1662d5 (patch)
tree7c882894e2767f502c4a7cadb1b9e2950c40bcc7
downloadaur-7ef8fd23b4df883a3a56e673b530e9cf4f1662d5.tar.gz
v0.8.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD33
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5c9ce9a7504
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-flexx
+ pkgdesc = Write desktop and web apps in pure Python
+ pkgver = 0.8.0
+ pkgrel = 1
+ url = https://flexx.readthedocs.io
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-tornado
+ depends = python-pscript>=0.7.1
+ depends = python-webruntime>=0.5.6
+ depends = python-dialite>=0.5.2
+ source = python-flexx-0.8.0.tar.gz::https://github.com/flexxui/flexx/archive/v0.8.0.tar.gz
+ sha256sums = 994fbb5b433012b93db13759514e15a84facb57824adb6194a24378425ee6c10
+
+pkgname = python-flexx
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..14e16283ac23
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/src
+/*.pkg.tar
+/*.pkg.tar.xz
+/python-flexx-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b63b235e201a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Ronuk Raval <ronuk.raval at gmail dot com>
+
+pkgname=python-flexx
+pkgver=0.8.0
+pkgrel=1
+pkgdesc="Write desktop and web apps in pure Python"
+arch=('any')
+url="https://flexx.readthedocs.io"
+license=('BSD')
+depends=(
+ python
+ python-tornado
+ 'python-pscript>=0.7.1'
+ 'python-webruntime>=0.5.6'
+ 'python-dialite>=0.5.2'
+)
+source=(
+ ${pkgname}-${pkgver}.tar.gz::https://github.com/flexxui/flexx/archive/v${pkgver}.tar.gz
+)
+sha256sums=(
+ 994fbb5b433012b93db13759514e15a84facb57824adb6194a24378425ee6c10
+)
+
+build() {
+ cd "flexx-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "flexx-${pkgver}"
+ python setup.py install --skip-build --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}