summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-08-17 11:02:12 -0500
committerCarlos Aznarán2024-08-17 11:02:12 -0500
commitee2fc3fca2a700f86b83746c6c8800509f49d625 (patch)
tree2758e2c5e65efa43eccaafa6980cd1c74cf6c7f3
parent9bd44dbb05a40ca9483b0f144a4dde06824108d4 (diff)
downloadaur-ee2fc3fca2a700f86b83746c6c8800509f49d625.tar.gz
Bump version to 0.6.5
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61a4074864d7..e2c95d2eef37 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-fluiddyn
pkgdesc = Framework for studying fluid dynamics
- pkgver = 0.6.4
+ pkgver = 0.6.5
pkgrel = 1
url = https://foss.heptapod.net/fluiddyn/fluiddyn
arch = any
@@ -10,7 +10,7 @@ pkgbase = python-fluiddyn
checkdepends = ipython
makedepends = python-build
makedepends = python-installer
- makedepends = python-pdm
+ makedepends = python-pdm-backend
makedepends = python-wheel
depends = python-matplotlib
depends = python-h5netcdf
@@ -20,7 +20,9 @@ pkgbase = python-fluiddyn
optdepends = python-pyfftw: Calculate FFT
optdepends = python-pulp: LP problem support
optdepends = python-mpi4py: MPI support
- source = https://foss.heptapod.net/fluiddyn/fluiddyn/-/archive/0.6.4/fluiddyn-0.6.4.tar.gz
- sha512sums = 1317162795e3577d63d3a739d43936af54382f906aa06bf2f8992265eed43b5e6cfaf0635a675fbe8520faed1ede617ea11632c53084a739ff61785f8c07ae29
+ optdepends = python-scikit-image
+ optdepends = python-opencv
+ source = https://foss.heptapod.net/fluiddyn/fluiddyn/-/archive/0.6.5/fluiddyn-0.6.5.tar.gz
+ sha512sums = 55a196344a1ac7d578716acd9789e3489c96787c4ddda42b7c03c289f1fb59caf9f1c25474fdd828c815659de4ec37a83ea11991c2b573c55cb17e146fa6258a
pkgname = python-fluiddyn
diff --git a/PKGBUILD b/PKGBUILD
index 26caaa8c50cf..cec7131f2ecd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
# Contributor: Ashwin <ashwinvis+arch_@t_Pr0t0nM4il_c0m>
_base=fluiddyn
pkgname=python-${_base}
-pkgver=0.6.4
+pkgver=0.6.5
pkgrel=1
pkgdesc="Framework for studying fluid dynamics"
arch=(any)
url="https://foss.heptapod.net/${_base}/${_base}"
license=(CECILL-B)
depends=(python-matplotlib python-h5netcdf python-psutil python-distro python-simpleeval)
-makedepends=(python-build python-installer python-pdm python-wheel)
+makedepends=(python-build python-installer python-pdm-backend python-wheel)
optdepends=('python-pyfftw: Calculate FFT'
'python-pulp: LP problem support'
- 'python-mpi4py: MPI support')
-# 'python-shtns' 'python-scikit-image' 'python-opencv'
+ 'python-mpi4py: MPI support'
+ 'python-scikit-image'
+ 'python-opencv') # 'python-shtns'
checkdepends=(python-pytest python-scipy ipython)
source=(${url}/-/archive/${pkgver}/${_base}-${pkgver}.tar.gz)
-sha512sums=('1317162795e3577d63d3a739d43936af54382f906aa06bf2f8992265eed43b5e6cfaf0635a675fbe8520faed1ede617ea11632c53084a739ff61785f8c07ae29')
+sha512sums=('55a196344a1ac7d578716acd9789e3489c96787c4ddda42b7c03c289f1fb59caf9f1c25474fdd828c815659de4ec37a83ea11991c2b573c55cb17e146fa6258a')
build() {
cd ${_base}-${pkgver}