summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2018-06-26 22:44:49 +0200
committereolianoe2018-06-26 22:44:49 +0200
commit172cc7099a79acffe478bd55c4918cf14781011a (patch)
treecf6521fe15770223f67e3ff78793b8d0d490a202
parente8ebbe4ae676d6d89e80c90484bc01a1c9ded0ea (diff)
downloadaur-172cc7099a79acffe478bd55c4918cf14781011a.tar.gz
build both python and python2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 34 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a4c7f48344e..02d79752916c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,24 @@
# Generated by mksrcinfo v8
-# Tue Jan 16 14:43:54 UTC 2018
+# Tue Jun 26 20:44:36 UTC 2018
pkgbase = python-flup
pkgdesc = A collection of Python WSGI modules
- pkgver = 1.0.2
- pkgrel = 5
+ pkgver = 1.0.3
+ pkgrel = 1
url = https://www.saddi.com/software/flup/
arch = any
license = MIT
makedepends = python2-distribute
- depends = python2
+ makedepends = python-distribute
conflicts = python-flup<=1.0.2-3
replaces = python-flup<=1.0.2-3
- source = http://www.saddi.com/software/flup/dist/flup-1.0.2.tar.gz
+ source = https://pypi.python.org/packages/source/f/flup/flup-1.0.3.tar.gz
source = LICENSE
- md5sums = 24dad7edc5ada31dddd49456ee8d5254
+ md5sums = a64e7a6374e043480ee92534c735964e
md5sums = 2b61db5f66aad3b1748085e146603bd1
pkgname = python2-flup
+ depends = python2
+
+pkgname = python-flup
+ depends = python
diff --git a/PKGBUILD b/PKGBUILD
index fd9bb31ac486..7c84b090ce99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,44 @@
# Contributor: Aaron Schaefer <aaron@elasticdog.com>
pkgbase=python-flup
-pkgname=python2-flup
-pkgver=1.0.2
-pkgrel=5
+pkgname=('python2-flup' 'python-flup')
+pkgver=1.0.3
+pkgrel=1
pkgdesc='A collection of Python WSGI modules'
arch=('any')
url='https://www.saddi.com/software/flup/'
license=('MIT')
-depends=('python2')
-makedepends=('python2-distribute')
conflicts=('python-flup<=1.0.2-3')
replaces=('python-flup<=1.0.2-3')
-source=("http://www.saddi.com/software/flup/dist/flup-$pkgver.tar.gz"
+makedepends=('python2-distribute' 'python-distribute')
+source=("https://pypi.python.org/packages/source/f/flup/flup-${pkgver}.tar.gz"
'LICENSE')
-md5sums=('24dad7edc5ada31dddd49456ee8d5254'
+md5sums=('a64e7a6374e043480ee92534c735964e'
'2b61db5f66aad3b1748085e146603bd1')
-package_python2-flup() {
- cd "$srcdir/flup-$pkgver"
+prepare() {
+ rm -rf -- "${srcdir}/flup-${pkgver}-py2"
+ cp -a -- "${srcdir}/flup-${pkgver}"{,-py2}
+ cd "$srcdir/flup-$pkgver-py2"
# python2 fix
for file in flup/server/*.py; do
sed -i 's_#!/usr/bin/env python_#!/usr/bin/env python2_' $file
done
+}
+
+package_python-flup() {
+ depends=('python')
+ cd "$srcdir/flup-$pkgver"
+
+ python setup.py install --root="$pkgdir"
+
+ install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+package_python2-flup() {
+ depends=('python2')
+ cd "$srcdir/flup-$pkgver-py2"
python2 setup.py install --root="$pkgdir"