summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2017-03-25 11:04:46 -0400
committerGuillaume Horel2017-03-25 11:04:46 -0400
commitadbff1c5fcd1dbdb2ba3ad86829836c30a458c57 (patch)
tree0aea7657ae153c0c9cc09d32bacbd37e950780e3
downloadaur-adbff1c5fcd1dbdb2ba3ad86829836c30a458c57.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4f1bf2f1fa7a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-folium
+ pkgdesc = Python Data. Leaflet.js maps.
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/python-vizualisation/folium
+ arch = any
+ license = BSD
+ checkdepends = python-nose
+ checkdepends = python-descartes
+ depends = python
+ depends = python-jinja
+ depends = python-branca
+ options = !emptydirs
+ source = https://github.com/python-visualization/folium/archive/v0.3.0.tar.gz
+ sha256sums = 317cbb1d73a8b241b50bf01c0db1a7004742bded2336577bc8b619280875590f
+
+pkgname = python-folium
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96b7f4b59bb1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=python-folium
+_pkgname=folium
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Python Data. Leaflet.js maps."
+arch=('any')
+url="https://github.com/python-vizualisation/folium"
+license=('BSD')
+checkdepends=('python-nose' 'python-descartes')
+depends=('python' 'python-jinja' 'python-branca')
+options=(!emptydirs)
+source=("https://github.com/python-visualization/$_pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('317cbb1d73a8b241b50bf01c0db1a7004742bded2336577bc8b619280875590f')
+
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ nosetests
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/$pkgname/LICENSE.txt"
+}