summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-12-14 01:16:16 +0300
committerCaleb Maclennan2021-12-14 01:16:16 +0300
commit000c5f32b7ac62461590aeb8b4286703682ca49c (patch)
tree14ed256722a3af0952be8459be18e4a78ab2be50
parentb79860609b9c9fef41505144d089450aded4a871 (diff)
downloadaur-000c5f32b7ac62461590aeb8b4286703682ca49c.tar.gz
upgpkg: python-fontdoctools 1.1-2
Rebuild for Python 3.10
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16f8b34ddbc1..1285f24c4a86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-fontdoctools
pkgdesc = tools that help in documenting and reviewing the design or the engineering of fonts
pkgver = 1.1
- pkgrel = 1
+ pkgrel = 2
url = https://bitbucket.org/LindenbergSW/fontdoctools
arch = any
license = MIT
@@ -13,8 +13,7 @@ pkgbase = python-fontdoctools
provides = glyhpsandwich
provides = glyphshaper
provides = roentgen
- source = python-fontdoctools-1.1.zip::https://bitbucket.org/LindenbergSW/fontdoctools/get/5f2880db5e08.zip
+ source = LindenbergSW-fontdoctools-5f2880db5e08.zip::https://bitbucket.org/LindenbergSW/fontdoctools/get/5f2880db5e08.zip
sha256sums = ea86f79b851dc28f62c2ec3ca5824a7906ed97688b96b0170de4f1a5b455be7c
pkgname = python-fontdoctools
-
diff --git a/PKGBUILD b/PKGBUILD
index a3007bebee40..a84205c33f45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,26 +4,27 @@ _pipname=fontdoctools
pkgname=python-$_pipname
_sha=5f2880db5e08
pkgver=1.1
-pkgrel=1
+pkgrel=2
pkgdesc='tools that help in documenting and reviewing the design or the engineering of fonts'
-arch=('any')
+arch=(any)
_namespace=LindenbergSW
url="https://bitbucket.org/$_namespace/$_pipname"
-license=('MIT')
-_py_deps=('fonttools')
-depends=('python'
+license=(MIT)
+_py_deps=(fonttools)
+depends=(python
"${_py_deps[@]/#/python-}")
-provides=('dottedcircleshaper' 'glyphplotter' 'glyhpsandwich' 'glyphshaper' 'roentgen')
-makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.zip::$url/get/$_sha.zip")
+provides=(dottedcircleshaper glyphplotter glyhpsandwich glyphshaper roentgen)
+makedepends=(python-setuptools)
+_archive="$_namespace-$_pipname-$_sha"
+source=("$_archive.zip::$url/get/$_sha.zip")
sha256sums=('ea86f79b851dc28f62c2ec3ca5824a7906ed97688b96b0170de4f1a5b455be7c')
build() {
- cd "$_namespace-$_pipname-$_sha"
+ cd "$_archive"
python setup.py build
}
package() {
- cd "$_namespace-$_pipname-$_sha"
+ cd "$_archive"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}