summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-03 16:52:00 +0300
committerCaleb Maclennan2021-08-03 16:52:00 +0300
commit9a317080eb833cefcc2fe3aa7112e1e2264f6cdb (patch)
tree4c6f36e869e5a5d18652d29b700a5b7ccbea4983
parentd611a1d0297ac35038b94b30489293d99f2dfaa1 (diff)
downloadaur-9a317080eb833cefcc2fe3aa7112e1e2264f6cdb.tar.gz
upgpkg: python-fontmath 0.8.1-2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD53
-rw-r--r--install.patch11
3 files changed, 31 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bed414b0192d..776eabeaddaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
pkgbase = python-fontmath
- pkgdesc = A set of objects for performing math operations on font data.
+ pkgdesc = A collection of objects that implement fast font, glyph, etc. math
pkgver = 0.8.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/robotools/fontMath
arch = any
license = MIT
checkdepends = python-pytest
- makedepends = python-setuptools
+ makedepends = python-setuptools-scm
depends = python-fonttools
- options = !emptydirs
- source = https://pypi.org/packages/source/f/fontMath/fontMath-0.8.1.zip
- source = install.patch
+ source = https://files.pythonhosted.org/packages/source/f/fontMath/fontMath-0.8.1.zip
sha256sums = 39d71e8b7eeb33c0ddc25e94c1ae64bf29340aeea443f4327392f2be38175f54
- sha256sums = 12aff8540624a75b549dedf9483da84c9e66bca165a021d57be9f3469071baca
pkgname = python-fontmath
diff --git a/PKGBUILD b/PKGBUILD
index e009fc819a52..50786eded3fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,35 @@
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-# Ex-Maintainer: William Turner <willtur.will@gmail.com>
-pkgname='python-fontmath'
-_pkgname=fontMath
-pkgver=0.8.1
-pkgrel=1
-pkgdesc='A set of objects for performing math operations on font data.'
-arch=('any')
-url='https://github.com/robotools/fontMath'
-license=('MIT')
-makedepends=('python-setuptools')
-depends=('python-fonttools')
-checkdepends=('python-pytest')
-options=(!emptydirs)
-source=("https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.zip"
- "install.patch")
-sha256sums=('39d71e8b7eeb33c0ddc25e94c1ae64bf29340aeea443f4327392f2be38175f54'
- '12aff8540624a75b549dedf9483da84c9e66bca165a021d57be9f3469071baca')
+# Contributor: William Turner <willtur.will@gmail.com>
-prepare() {
- cd "$_pkgname-$pkgver"
- patch -p1 -i ../install.patch
-}
+_pyname=fontMath
+pkgname=python-${_pyname,,}
+pkgver=0.8.1
+pkgrel=2
+pkgdesc='A collection of objects that implement fast font, glyph, etc. math'
+arch=(any)
+url="https://github.com/robotools/$_pyname"
+license=(MIT)
+depends=(python-fonttools)
+checkdepends=(python-pytest)
+makedepends=(python-setuptools-scm)
+_archive="$_pyname-$pkgver"
+source=("https://files.pythonhosted.org/packages/source/${_pyname::1}/$_pyname/$_archive.zip")
+sha256sums=('39d71e8b7eeb33c0ddc25e94c1ae64bf29340aeea443f4327392f2be38175f54')
-package() {
- cd "$_pkgname-$pkgver"
- python setup.py install --root=$pkgdir || return 1
- install -D -m644 License.txt "${pkgdir}/usr/share/licenses/${pkgname}/License.txt"
+build() {
+ cd "$_archive"
+ export PYTHONHASHSEED=0
+ python setup.py build
}
check() {
- cd "$_pkgname-$pkgver"
+ cd "$_archive"
PYTHONPATH=Lib pytest Lib/fontMath/test
}
+
+package() {
+ cd "$_archive"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm0644 -t "$pkgdir/usr/share/licenses/$pkgname/" License.txt
+}
diff --git a/install.patch b/install.patch
deleted file mode 100644
index 5964e554b400..000000000000
--- a/install.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -urN fontMath-0.8.1-orig/setup.py fontMath-0.8.1/setup.py
---- fontMath-0.8.1-orig/setup.py 2021-07-19 18:10:45.934845200 -0400
-+++ fontMath-0.8.1/setup.py 2021-07-19 18:10:57.344850599 -0400
-@@ -27,7 +27,6 @@
- "write_to": 'Lib/fontMath/_version.py',
- "write_to_template": '__version__ = "{version}"',
- },
-- setup_requires=pytest_runner + wheel + ['setuptools_scm'],
- tests_require=[
- 'pytest>=3.0.3',
- ],