summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-07-19 18:19:33 -0400
committerGuillaume Horel2021-07-19 18:19:33 -0400
commitd611a1d0297ac35038b94b30489293d99f2dfaa1 (patch)
tree9c1815fab4b5a4551837ee75509195136aaa3702
parent3880aa4692b09b557b30dbbddb158fc941f20b8d (diff)
downloadaur-d611a1d0297ac35038b94b30489293d99f2dfaa1.tar.gz
fix dependencies
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
-rw-r--r--install.patch11
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b093d1219376..bed414b0192d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,11 +6,12 @@ pkgbase = python-fontmath
arch = any
license = MIT
checkdepends = python-pytest
- checkdepends = python-pytest-runner
makedepends = python-setuptools
depends = python-fonttools
options = !emptydirs
source = https://pypi.org/packages/source/f/fontMath/fontMath-0.8.1.zip
+ source = install.patch
sha256sums = 39d71e8b7eeb33c0ddc25e94c1ae64bf29340aeea443f4327392f2be38175f54
+ sha256sums = 12aff8540624a75b549dedf9483da84c9e66bca165a021d57be9f3469071baca
pkgname = python-fontmath
diff --git a/PKGBUILD b/PKGBUILD
index a07d15b1e920..e009fc819a52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,17 @@ url='https://github.com/robotools/fontMath'
license=('MIT')
makedepends=('python-setuptools')
depends=('python-fonttools')
-checkdepends=('python-pytest' 'python-pytest-runner')
+checkdepends=('python-pytest')
options=(!emptydirs)
-source=("https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.zip")
-sha256sums=('39d71e8b7eeb33c0ddc25e94c1ae64bf29340aeea443f4327392f2be38175f54')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/${_pkgname}/${_pkgname}-${pkgver}.zip"
+ "install.patch")
+sha256sums=('39d71e8b7eeb33c0ddc25e94c1ae64bf29340aeea443f4327392f2be38175f54'
+ '12aff8540624a75b549dedf9483da84c9e66bca165a021d57be9f3469071baca')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -p1 -i ../install.patch
+}
package() {
cd "$_pkgname-$pkgver"
@@ -23,5 +30,5 @@ package() {
check() {
cd "$_pkgname-$pkgver"
- python setup.py test
+ PYTHONPATH=Lib pytest Lib/fontMath/test
}
diff --git a/install.patch b/install.patch
new file mode 100644
index 000000000000..5964e554b400
--- /dev/null
+++ b/install.patch
@@ -0,0 +1,11 @@
+diff -urN fontMath-0.8.1-orig/setup.py fontMath-0.8.1/setup.py
+--- fontMath-0.8.1-orig/setup.py 2021-07-19 18:10:45.934845200 -0400
++++ fontMath-0.8.1/setup.py 2021-07-19 18:10:57.344850599 -0400
+@@ -27,7 +27,6 @@
+ "write_to": 'Lib/fontMath/_version.py',
+ "write_to_template": '__version__ = "{version}"',
+ },
+- setup_requires=pytest_runner + wheel + ['setuptools_scm'],
+ tests_require=[
+ 'pytest>=3.0.3',
+ ],