summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-08-17 21:35:13 -0400
committerGuillaume Horel2019-08-17 21:35:13 -0400
commit491e2ba681003534c333229a3f0197ed6a63303e (patch)
treef856e86548725656370e10bec894ec5845e95614
downloadaur-491e2ba681003534c333229a3f0197ed6a63303e.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..37e94eb02725
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-fontparts
+ pkgdesc = The replacement for RoboFab.
+ pkgver = 0.8.7
+ pkgrel = 1
+ url = https://github.com/robotools/fontParts
+ arch = any
+ license = MIT
+ checkdepends = python-fontpens
+ makedepends = python-setuptools
+ depends = python
+ depends = python-defcon
+ depends = python-fontmath
+ depends = python-fonttools
+ source = https://pypi.org/packages/source/f/fontParts/fontParts-0.8.7.zip
+ sha256sums = 8db7ee766f8a2e407dbbd6ce090987b9889e87ef7de71421e8379a7db9bf9d97
+
+pkgname = python-fontparts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0362e71ef15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-fontparts')
+_pkgname='fontParts'
+pkgver='0.8.7'
+pkgrel=1
+pkgdesc='The replacement for RoboFab.'
+url='https://github.com/robotools/fontParts'
+checkdepends=('python-fontpens')
+depends=('python' 'python-defcon' 'python-fontmath' 'python-fonttools')
+makedepends=('python-setuptools')
+optdepends=()
+license=('MIT')
+arch=('any')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip")
+sha256sums=('8db7ee766f8a2e407dbbd6ce090987b9889e87ef7de71421e8379a7db9bf9d97')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+#check() {
+ #cd "$srcdir/$_pkgname-$pkgver"
+ #PYTHONPATH=. python fontParts/fontshell/test.py
+#}
+